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Preface

Audience for This Guide
Welcome to Release 11i of Oracle Service Fulfillment Manager Implementation 
Guide.

This guide assumes you have a working knowledge of the following:

■ The principles and customary practices of your business area.

■ Oracle Service Fulfillment Manager

If you have never used Oracle Service Fulfillment Manager, Oracle suggests 
you attend one or more of the Oracle Service Fulfillment Manager training 
classes available through Oracle University.

■ The Oracle Applications graphical user interface. 

To learn more about the Oracle Applications graphical user interface, read the 
Oracle Applications User’s Guide.

See Other Information Sources for more information about Oracle Applications 
product information.

How To Use This Guide
This document contains the information you need to understand and use Oracle 
Service Fulfillment Manager.

■ Chapter 1 “Understanding Oracle Service Fulfillment Manager” provides 
overviews of the application and its components, explanations of key concepts, 
features, and functions, as well as the application’s relationships to other Oracle 
or third-party applications.
ix



■ Chapter 2“Using Oracle Service Fulfillment Manager” provides 
process-oriented, task based procedures for using the Oracle Service Fulfillment 
Manager to perform essential business tasks.

■ Chapter 3“Administering Oracle Service Fulfillment Manager,” provides 
task-based procedures for required for ongoing system maintenance and 
includes information on administration tools and utilities.

Documentation Accessibility 
Our goal is to make Oracle products, services, and supporting documentation 
accessible, with good usability, to the disabled community. To that end, our 
documentation includes features that make information available to users of 
assistive technology. This documentation is available in HTML format, and contains 
markup to facilitate access by the disabled community. Standards will continue to 
evolve over time, and Oracle Corporation is actively engaged with other 
market-leading technology vendors to address technical obstacles so that our 
documentation can be accessible to all of our customers. For additional information, 
visit the Oracle Accessibility Program Web site at 
http://www.oracle.com/accessibility/. 

Accessibility of Code Examples in Documentation
JAWS, a Windows screen reader, may not always correctly read the code examples 
in this document. The conventions for writing code require that closing braces 
should appear on an otherwise empty line; however, JAWS may not always read a 
line of text that consists solely of a bracket or brace. 

Other Information Sources
You can choose from many sources of information, including online 
documentation, training, and support services, to increase your knowledge and 
understanding of Oracle Service Fulfillment Manager.

If this guide refers you to other Oracle Applications documentation, use only the 
Release 11i versions of those guides.

Online Documentation
All Oracle Applications documentation is available online (HTML or PDF). Online 
help patches are available on MetaLink.
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Related Documentation
Oracle Service Fulfillment Manager shares business and setup information with 
other Oracle Applications products. Therefore, you may want to refer to other 
product documentation when you set up and use Oracle Service Fulfillment 
Manager.

You can read the documents online by choosing Library from the expandable menu 
on your HTML help window, by reading from the Oracle Applications Document 
Library CD included in your media pack, or by using a Web browser with a URL 
that your system administrator provides.

If you require printed guides, you can purchase them from the Oracle Store at 
http://oraclestore.oracle.com.

Documents Related to All Products

Oracle Applications User’s Guide
This guide explains how to enter data, query, run reports, and navigate using 
the graphical user interface (GUI) available with this release of Oracle Service 
Fulfillment Manager (and any other Oracle Applications products). This guide also 
includes information on setting user profiles, as well as running and reviewing 
reports and concurrent processes.

You can access this user’s guide online by choosing ”Getting Started with Oracle 
Applications” from any Oracle Applications help file.

Documents Related to This Product

Oracle Service Fulfillment Manager Implementation Guide
This guide provides information required for implementing and setting up 
Installation and System Administration

Oracle Applications Concepts
This guide provides an introduction to the concepts, features, technology stack, 
architecture, and terminology for Oracle Applications Release 11i. It provides a 
useful first book to read before an installation of Oracle Applications. This guide 
also introduces the concepts behind Applications-wide features such as Business 
Intelligence (BIS), languages and character sets, and Self-Service Web Applications.
xi



Installing Oracle Applications
This guide provides instructions for managing the installation of Oracle 
Applications products. This guide contains instructions for using Oracle Rapid 
Install and lists the tasks you need to perform to finish your installation. You 
should use this guide in conjunction with individual product user’s guides and 
implementation guides.

Oracle Applications Supplemental CRM Installation Steps
This guide contains specific steps needed to complete installation of a few of the 
CRM products. The steps should be done immediately following the tasks given in 
the Installing Oracle Applications guide.

Upgrading Oracle Applications
Refer to this guide if you are upgrading your Oracle Applications Release 10.7 or 
Release 11.0 products to Release 11i. This guide describes the upgrade process and 
lists database and product-specific upgrade tasks. You must be either at Release 10.7 
(NCA, SmartClient, or character mode) or Release 11.0, to upgrade to Release 11i. 
You cannot upgrade to Release 11i directly from releases prior to 10.7.

Maintaining Oracle Applications
Use this guide to help you run the various AD utilities, such as AutoUpgrade, 
AutoPatch, AD Administration, AD Controller, AD Relink, License Manager, and 
others. It contains how-to steps, screenshots, and other information that you need to 
run the AD utilities. This guide also provides information on maintaining the 
Oracle applications file system and database.

Oracle Applications System Administrator’s Guide
This guide provides planning and reference information for the Oracle Applications 
System Administrator. It contains information on how to define security, customize 
menus and online help, and manage concurrent processing.

Oracle Alert User’s Guide
This guide explains how to define periodic and event alerts to monitor the status of 
your Oracle Applications data.

Oracle Applications Developer’s Guide
This guide contains the coding standards followed by the Oracle Applications 
development staff. It describes the Oracle Application Object Library components 
needed to implement the Oracle Applications user interface described in the Oracle 
xii



Applications User Interface Standards for Forms-Based Products. It also provides 
information to help you build your custom Oracle Forms Developer 6i forms so that 
they integrate with Oracle Applications.

Oracle Applications User Interface Standards for Forms-Based Products
This guide contains the user interface (UI) standards followed by the Oracle 
Applications development staff. It describes the UI for the Oracle Applications 
products and how to apply this UI to the design of an application built by using 
Oracle Forms.

Other Implementation Documentation

Oracle Workflow Guide
This guide explains how to define new workflow business processes as well as 
customize existing Oracle Applications-embedded workflow processes.You also use 
this guide to complete the setup steps necessary for any Oracle Applications 
product that includes workflow-enabled processes.

Oracle Applications Flexfields Guide
This guide provides flexfields planning, setup and reference information for the 
Oracle Service Fulfillment Manager implementation team, as well as for users 
responsible for the ongoing maintenance of Oracle Applications product data. This 
manual also provides information on creating custom reports on flexfields data.

Oracle eTechnical Reference Manuals
Each eTechnical Reference Manual (eTRM) contains database diagrams and a 
detailed description of database tables, forms, reports, and programs for a specific 
Oracle Applications product. This information helps you convert data from your 
existing applications, integrate Oracle Applications data with non-Oracle 
applications, and write custom reports for Oracle Applications products. Oracle 
eTRM is available on Metalink

Oracle Manufacturing APIs and Open Interfaces Manual
This manual contains up-to-date information about integrating with other Oracle 
Manufacturing applications and with your other systems. This documentation 
includes APIs and open interfaces found in Oracle Manufacturing.
xiii



Oracle Order Management Suite APIs and Open Interfaces Manual
This manual contains up-to-date information about integrating with other Oracle 
Manufacturing applications and with your other systems. This documentation 
includes APIs and open interfaces found in Oracle Order Management Suite.

Oracle Applications Message Reference Manual
This manual describes Oracle Applications messages. This manual is available in 
HTML format on the documentation CD-ROM for Release 11i.

Oracle CRM Application Foundation Implementation Guide
Many CRM products use components from CRM Application Foundation. Use this 
guide to correctly implement CRM Application Foundation.

Training and Support

Training
Oracle offers training courses to help you and your staff master Oracle Service 
Fulfillment Manager and reach full productivity quickly. You have a choice of 
educational environments. You can attend courses offered by Oracle University at 
any one of our many Education Centers, you can arrange for our trainers to teach at 
your facility, or you can use Oracle Learning Network (OLN), Oracle University’s 
online education utility. In addition, Oracle training professionals can tailor 
standard courses or develop custom courses to meet your needs. For example, you 
may want to use your organization’s structure, terminology, and data as examples 
in a customized training session delivered at your own facility.

Support
From on-site support to central support, our team of experienced professionals 
provides the help and information you need to keep Oracle Service Fulfillment 
Manager working for you. This team includes your Technical Representative, 
Account Manager, and Oracle’s large staff of consultants and support specialists 
with expertise in your business area, managing an Oracle8i server, and your 
hardware and software environment.

Oracl eMetaLink
OracleMetaLink is your self-service support connection with web, telephone menu, 
and e-mail alternatives. Oracle supplies these technologies for your convenience, 
available 24 hours a day, 7 days a week. With OracleMetaLink, you can obtain 
information and advice from technical libraries and forums, download patches, 
xiv



download the latest documentation, look at bug details, and create or update TARs. 
To use MetaLink, register at (http://metalink.oracle.com).

Alerts: You should check OracleMetaLink alerts before you begin to install or 
upgrade any of your Oracle Applications. Navigate to the Alerts page as follows: 
Technical Libraries/ERP Applications/Applications Installation and 
Upgrade/Alerts.

Self-Service Toolkit: You may also find information by navigating to the 
Self-Service Toolkit page as follows: Technical Libraries/ERP 
Applications/Applications Installation and Upgrade.

Do Not Use Database Tools to Modify Oracle Applications Data
Oracle STRONGLY RECOMMENDS that you never use SQL*Plus, Oracle Data 
Browser, database triggers, or any other tool to modify Oracle Applications data 
unless otherwise instructed.

Oracle provides powerful tools you can use to create, store, change, retrieve, and 
maintain information in an Oracle database. But if you use Oracle tools such as 
SQL*Plus to modify Oracle Applications data, you risk destroying the integrity of 
your data and you lose the ability to audit changes to your data.

Because Oracle Applications tables are interrelated, any change you make using 
Oracle Applications can update many tables at once. But when you modify Oracle 
Applications data using anything other than Oracle Applications, you may change a 
row in one table without making corresponding changes in related tables. If your 
tables get out of synchronization with each other, you risk retrieving erroneous 
information and you risk unpredictable results throughout Oracle Applications.

When you use Oracle Applications to modify your data, Oracle Applications 
automatically checks that your changes are valid. Oracle Applications also keeps 
track of who changes information. If you enter information into database tables 
using database tools, you may store invalid information. You also lose the ability to 
track who has changed your information because SQL*Plus and other database 
tools do not keep a record of changes.

About Oracle
Oracle Corporation develops and markets an integrated line of software products 
for database management, applications development, decision support, and office 
automation, as well as Oracle Applications, an integrated suite of more than 160 
software modules for financial management, supply chain management, 
xv



manufacturing, project systems, human resources and customer relationship 
management.

Oracle products are available for mainframes, minicomputers, personal computers, 
network computers and personal digital assistants, allowing organizations to 
integrate different computers, different operating systems, different networks, and 
even different database management systems, into a single, unified computing and 
information resource.

Oracle is the world’s leading supplier of software for information management, and 
the world’s second largest software company. Oracle offers its database, tools, and 
applications products, along with related consulting, education, and support 
services, in over 145 countries around the world.
xvi



Implementing Oracle Service Fulfillment Ma
1

Implementing Oracle Service Fulfillment Manager

1.1 Considerations for Planning an Implementation Project
The following items are part of planning an Oracle Service Fulfillment Manager 
Implementation:

■ Overview of Oracle Service Fulfillment Manager

■ Application architecture

■ Features and functions

■ User roles

■ Other considerations

The Benefits of Oracle Service Fulfillment Manager
Oracle Service Fulfillment Manager provides the following benefits:

■ A fully automated, nearly real-time activation of services for multiple network 
elements in a multivendor network environment. 

■ A number of APIs (Application Program Interfaces) that you can use as 
building blocks in creating an interface to any Operational Support System 
(OSS) available on the service provider’s network. For example, you can use 
these APIs to create an interface to an external order entry or customer care 
system.
nager 1-1



Considerations for Planning an Implementation Project
Features of Oracle Service Fulfillment Manager
Oracle Service Fulfillment Manager is designed to be an integrated management 
system that acts as the coordinating link between different external systems. It 
supports the following features:

■ The rapid deployment of new services by integrating the functions of service 
management with the network details such as service attributes, Service 
Fulfillment Manager algorithms, and fulfillment elements.

■ The Service Fulfillment Manager of multiple technologies such as ATM, ADSL, 
switches, routers.

■ The delivery of complex services requiring configuration of multiple fulfillment 
elements and OSS (Operational Support Systems) interfaces.

■ The delivery of bundled services combining voice, data and video products. 

1.1.1 Application Architecture

Oracle Service Fulfillment Manager Architecture
The Oracle Service Fulfillment Manager architecture consists of three functional 
layers:

■ The application interface layer

The application interface layer performs the mediation function with external 
systems. This layer is made of API sets implemented in various interfaces 
implemented through PL/SQL remote procedure calls.

■ The workflow management layer

The workflow management layer performs order processing.

■ The communications management layer

The Communications Management layer is responsible for managing 
communications between SFM and the network elements. This activity is 
handled though the Connection Management Utility (CMU) module.

Components
The basic components which make up Oracle Service Fulfillment Manager are as 
follows:

■ Order Capture through Process Order  and Order interface.

■ Ability to Resubmit Orders
1-2 Oracle Service Fulfillment Manager Implementation Guide



Considerations for Planning an Implementation Project
■ Order Management through the Flow Through Module

■ Connection Management Utility acting as a gateway to OSSs, FEs, NEs

■ Order Fallout and Repair through the Fallout Management Center

■ Service Definition through the Service Creation Manager Module

■ Order Queue Processing Management through the System Console

■ Set-up of Service Providers

■ Ability to Create Messages for send/receive to any external system.

1.1.2 Features and Functions
Oracle Service Fulfillment Manager provides three major functions:

Service Fulfillment
Through PL/SQL procedures calls, Oracle Service Fulfillment Manager provides 
mechanisms for performing the following tasks:

■ Submitting orders

■ Obtaining order statuses

■ Receiving error notification

■ Responding to error notifications

The Service Fulfillment function also provides the capabilities for Service Creation, 
Package Creation, Workitem Creation, Workflow Customization, handling of 
Fulfillment Elements, handling for Fulfillment Element Types, and other Service 
Fulfillment Manager Procedure capabilities. These capabilities will be covered in 
greater detail during the Instructor Lead Training (ILT).

Administration
Oracle Service Fulfillment Manager has established procedures for User 
Administration, Security, Console, and Connection Management (through the 
Connection Management Utility - CMU), througput of order processing (through 
the System Console). These subject will be covered in greater detail during the ILT.

Operations
Oracle Service Fulfillment Manager Operations consists of Flow Through 
Management and Fallout Management (through the Fallout Management Center 
Implementing Oracle Service Fulfillment Manager 1-3
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(FMC). These two modules are discussed in the following section and are covered in 
even greater detail during the ILT.

1.1.3 Service Order Requests in Oracle Service Fulfillment Manager
Oracle Service Fulfillment Manager handles a typical service order request by 
performing the following tasks:

1. Capturing a service order request

2. Validating the order

3. Analyzing the order

4. Fulfilling the order

5. Completing the order

6. Managing order fallout (if needed)

Capturing a Service Order Request
Initially, a customer places an order with the carrier for a telecommunication 
service. Examples of services are phone line connections, Internet connections or 
wireless access.

Customer orders are captured from an external order entry system. If necessary, you 
can use the Oracle Service Fulfillment Manager screens to input customer orders. 
However, as the name of the form indicates the purpose of the Test Center. The 
primary capture process is through the Oracle Service Fulfillment Manager APIs. 

Validating the Order
After the service order is captured by the system (or manually entered, as the case 
may be), it is examined for validity by the system. If an order fails validation, SFM 
returns an appropriate message indicating such errors to the order originator. Failed 
orders due to validation errors are not processed further in Oracle Service 
Fulfillment Manager. 

Order validation includes verifying:

■ The order syntax

■ The inclusion of mandatory parameters

■ The inclusion of necessary dependent information

■ The supplied dates are valid
1-4 Oracle Service Fulfillment Manager Implementation Guide
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Analyzing the Order
After the system captures an order, Oracle Service Fulfillment Manager performs 
the following steps:

1. It first analyzes the order.

2. It then breaks down the order into the required set of tasks needed to complete 
the order.

3. Finally, it orders the tasks so that they will be performed in the proper 
sequence. 

For example, say a new order requires two new lines to be activated at a customer 
residence. The first line is an analog voice phone line. The second line is a digital 
ISDN line to be used for high-speed Internet access. In addition, each separate line 
is to have a different bundle of services associated with it. The analog line must 
have basic voice service, as well as the Caller ID and Call Waiting features. The 
digital line needs to have a connection established to the desired ISP (Internet 
Service Provider). 

After order capture, Oracle Service Fulfillment Manager analyzes and validates the 
order, and then puts the order steps into sequence. While some of the tasks involved 
in setting the customer order can be performed in parallel, others must be 
performed in a definite sequence. In this example, you must establish basic voice 
service on the analog line before implementing the additional features.

Fulfilling the Order
 Oracle Service Fulfillment Manager accomplishes order fulfillment through one of 
two ways:

■ SFM performs the requested tasks internally.

■ SFM directs external systems to perform the tasks involved in setting up the 
order.

Oracle Service Fulfillment Manager first translates these tasks into network 
language, and then activates the various network elements needed to complete the 
tasks. 

For example:

■ First, it can request configuration and activation of services on specific switches. 
(Connections to the needed network elements are managed using the 
Connection Manager.)
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■ Then, it can notify the OSS (Operational Support Systems) to commence these 
service.

Workflow manages the tasks involved in setting up an order. Workflow is either 
internal to Oracle Service Fulfillment Manager or external to it. 

■ Internal workflow: This is the default, or standard workflow delivered with the 
application.

■ External workflow: You create this workflow, and integrate it with the 
standard workflow delivered with the application. You configure workflow to 
match your company specific business practices.

Completing the Order
A Service Fulfillment Manager order can complete either successfully, or 
unsuccessfully. 

■ Order Completion Successful: Upon the completion of an order sucessfully an 
event is raised with status of SUCCESS.

■ Order Completion Unsuccessful: When an order fails the order goes to an 
ERROR status/ Upon checking the error notification, users can change/modify 
the order if necessary and continue process the order.

To Continue Processing you may modify the order from the Notifications Utility or 
resume the order from the point of failure

Note: Oracle Service Fulfillment Manager can also handle the 
results of the network elements through its generic fulfillment 
engine. 
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Managing Order Fallout
Order fulfillment can fail during the Service Fulfillment Manager process due to 
invalid activation information, or perhaps the unavailability of a needed network 
element. 

Oracle Service Fulfillment Manager provides a number of ways to effectively 
manage the order fallout process through its Notifications utility.

You can, for example:

■ Examine order details and drill down to error messages

■ Track the progress of problem resolutions through the system

■ Initiate action to reconfigure a service, if needed

■ Generate a notification and forward the notification to the Trouble Ticket 
system and/or Work Force Managements

■ Confirm that the order trouble has been cleared

Why Service Fulfillment Manager Orders Fail
Order fulfillment can fail during the Service Fulfillment Manager process due to the 
following factors:

■ Invalid orders: Orders that fail the order validation process may require 
escalation to the order entry or customer service groups. In such cases, the 
Notifications utility serves as a tracking and notification mechanism.

■ Bad or missing data: Incorrect or missing data can cause order fallout.

■ Fulfillment action problems: Fulfillment elements may not function properly, 
be too busy, or be unavailable, so the system rejects the service activation 
command.

■ Time-outs on orders: The connection session between the application and the 
fulfillment elements may time-out due to either application or to external 
errors. Orders that have timed out may have been partially completed prior to 
the time-out.

■ Network element or service configuration problems: The new service order 
may conflict with the current subscriber configuration. This may be the result of 
invalid orders. However, there may be other reasons, such as improper 
configuration of the customer.
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Ways to Resolve Failed Orders
You use the Notifications utility to track, monitor and resolve failed orders.

The table following details how you can resolve failed orders.

Table 1-1  Resolved failed orders

System Notification Types
As an order moves through the Service Fulfillment Manager process, the system can 
generate notifications in response to various events.

Example events are:

■ Recovery deamons

■ Service Service Fulfillment Manager process failure

Action Description

Retry Failed Orders You can re-send failed orders in one of the following ways:

■ Modify parameters in the failed order and re-send the 
order down to where the failure occurred, and then 
continue processing.

■ Re-send an unchanged order down to where the failure 
occurred in the Service Fulfillment Manager process. 
(Failure may have been due merely to network 
problems.)

■ Restart the Service Fulfillment Manager workflow from 
the point where it failed or stopped.

Stop Processing Failed 
Orders

You can stop the workflow processing of an order that is due 
for Service Fulfillment Manager. Stopping the workflow is 
useful in the case of identified network outages and order 
processing backlog.

Terminate Failed 
Workflows

You can completely terminate processing an order if the order 
encounters an exception state.

Resolve Failed Workflows You can correct the error in the order Service Fulfillment 
Manager workflow (from within the Notifications utility).

Escalate Failed Workflows You can escalate a failed order notification by forwarding it to 
another user or group to troubleshoot the order.

Re-assign Failed 
Workflows

You can reassign a failed order to another user or group for 
resolution.
1-8 Oracle Service Fulfillment Manager Implementation Guide



Considerations for Planning an Implementation Project
■ Internal exceptions

Notification types

The workflow produces two types of notifications:

■ Informative notifications: The system generates information notifications if the 
Service Delivery Platform system detects a stopped fulfillment element 
manager process and starts it up automatically. Also, the system generates this 
kind of notification if an internal problem occurs that requires a system 
administrator’s attention.

■ Order fallout notifications: The system generates an order fallout notification 
for failed orders. 

The Order Resubmission Utility
You use the Resubmission Utility to force the system to re-run an order on a 
fulfillment element. However, only those orders which have either completed, or 
have been previously submitted to the fulfillment element in question, can be 
resubmitted. You resubmit an order, for example, in the event that a network switch 
fails or experiences a service disruption, causing a Service Fulfillment Manager 
order to fail.

Through the Resubmission Utility, you specify a particular fulfillment element and 
the time window during which it was unavailable. After entering the required 
information, the fulfillment element re-executes the fulfillment actions as 
scheduled. For each resubmitted order, the system generates a unique Job ID. You 
can use the Job ID to track the progress of the resubmitted order.

Resubmitted Orders and Fulfillment Actions
Successful re-execution of the fulfillment action requires that the adapters run in 
this mode. 

■ If no adapters are available, and the fulfillment element adapter maximum has 
not been reached, then an error message is generated.

■ If no adapters can be started, all re-submission requests are queued.

You use the Resubmitted check box in the Order Flowthrough utility to identify 
resubmitted fulfillment actions.

Resubmitted Orders and Notifications
Resubmitted orders execute the same fulfillment procedure as original orders.
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■ These resubmitted orders can generate notifications based on the fulfillment 
procedure logic.

■ Any generated notification message includes the Job ID.

The Event Manager handles incoming and outgoing messages within the Oracle 
Service Fulfillment Manager. The Event Manager provides a set of APIs that 
internal and external systems use to register for messages.

■ Incoming messages are frequently a response to a previously initiated message 
from an external or internal system

■ Outgoing messages are frequently user-defined notifications informing an 
external or internal system of an event occurrence.

Message Registration
External applications can send request messages to the Event Manager, if they are 
registered for that message. External applications can also register for response 
messages.

Inbound Messages
The Event Manager identifies the subscriber and delivers an incoming message to 
the registered applications. The following sequence of steps is performed 
automatically. The Service Fulfillment Manager:

■ Picks up the message from the Incoming Queue

■ Pulls the message out of the Incoming Queue and into the Event Manager

■ Validates the message structure via the Event Manager

■ Verifies if any internal or external subscribers are registered for this message

■ Executes the user-defined logic

■ Delivers the message to all registered application systems

Processing Logic
If no application has registered for a message, then the application uses the default 
processing logic after message validation. External systems, however, can define the 
processing logic at the time when validation logic is defined.
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1.1.4 Queues in Oracle Service Fulfillment Manager
As a service order moves between the different stages in its processing, the order s 
often queued in one of the many internal system queues.

As the Service Fulfillment Manager of an order progresses, the order moves 
sequentially through the various system queues as part of the fulfillment process. 
The table following describes the queues that the Oracle Service Fulfillment 
Manager system uses.

Table 1-2  Oracle Service Fulfillment Manager Queues

Queue Contains

Orders Ready Orders that are ready to be provisioned immediately

Work Item Work items for orders currently being processed

(Work items are a logical grouping of fulfillment actions.)

Fulfillment Actions Fulfillment actions that are ready for execution

(Fulfillment actions execute fulfillment procedures on 
fulfillment elements.)

Wait for Resource Fulfillment actions waiting for one of the channels configured 
for the fulfillment elements to becomes available

Ready for Resource Fulfillment actions associated with each fulfillment element 
that are ready to be executed

Outbound Messages Messages sent by Oracle Service Fulfillment Manager

Inbound Messages Messages received by Oracle Service Fulfillment Manager

Event Manager Events which occur internally in Oracle Service Fulfillment 
Manager

Example events:

■ FA_done

■ Work Item_done

■ Lineitem_done
Implementing Oracle Service Fulfillment Manager 1-11



Considerations for Planning an Implementation Project
1.1.5 The Oracle Service Fulfillment Manager System Queues
As an order moves through the system, it progresses from queue to queue in a 
sequential manner. Typically, this progression moves through the system queues in 
the following order.

■ Order Ready Queue

■ Work Item Queue

■ Ready for Resource

Order Ready Queue
The Order Ready queue holds orders that are ready to be provisioned immediately. 
The order is dequeued from the Order Ready queue and the work items generated 
by the work-plan are placed on the work item queue. 

Work Item Queue
The system uses the work item queue to manage the execution of work items. 

Processing the work item involves the following actions:

■ Checking the configurator for existence of fulfillment actions mapped to the 
work items

The following then occurs:

■ With work items, the fulfillment actions are enqueued into the Ready for 
Resource in the sequence specified.

■ For user-defined workflows, the workflow determines the execution of the 
fulfillment actions. (Users can drag and drop EXECUTE_FA activities into their 
workflows based on the business process being implemented.)

Ready for Resource
The system uses the Ready for Resource to manage the execution of fulfillment 
actions for regular work items. 

Processing the fulfillment actions involves:

■ Checking the configuration to determine which fulfillment element is to receive 
the fulfillment procedure

■ Checking the availability of an adapter for the fulfillment element

The following then occurs:
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■ If an adapter is available, then it is immediately used to send the fulfillment 
element commands specified in the fulfillment procedure.

■ If all adapters for the fulfillment element are busy, or none are immediately 
available, the system enqueues the fulfillment action in the Wait for Resource 
queue. 
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1.1.6 Other Queues
The following queues are used as necessary:

■ Outbound, Inbound and Event Queues

■ FE Ready Queue

■ Wait for Resource Queue

Wait for Resource Queue
When an adapter becomes available, the system moves the fulfillment action 
waiting in the queue to the Ready for Resource queue.

FE Ready Queue
This is a temporary holder for all fulfillment actions that are waiting for a free 
fulfillment element adapter. As an adapter becomes available, the fulfillment action 
is immediately dequeued and its fulfillment procedure executed.

Outbound, Inbound and Event Queues
These queues are used by the Service Delivery Platform to communicate with 
asynchronous XML message based systems. 

1.1.7 The Queue Console
The Queue Console provides a set of screens that display specialized information 
about each internal system queue. It can also be used to track down an order and to 
take corrective actions to expedite the order fulfillment process.

The Queue Console provides the following information about each queue:

■ State Information

■ Process Information

■ Entry Information

State Information
The Queue Console displays information on the state or status of each Oracle 
Service Fulfillment Manager queue.

■ Enabled: The processors are up and running and processing orders.

■ Disabled: The processors are running, but an error condition has occurred. No 
order is being processed.
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■ Suspended: The processes have been suspended manually.

■ Shutdown: The processors have been shutdown manually.

Process Information
The Queue Console displays information on the processes that are registered or 
running for a queue.

■ Processors Registered: The number of processors pulling or processing orders 
out of a queue.

■ Processors Running: The number of orders running in a queue.

Entry Information
The Queue Console displays information the number and date of the entries in a 
queue.

■ No. of Entries: The number of entries in the queue.

■ Last Entry Date: The date when the last order entered this queue.   

1.1.8 Adapters
A network adapter mediates the communication between Oracle Service Fulfillment 
Manager and the fulfillment elements. 

■ Messages to be sent and received are specified by the fulfillment element and 
the connection procedures executed by Oracle Service Fulfillment Manager 
workflow. 

■ The Service Fulfillment Manager workflow executes connect procedures for 
each new fulfillment element connection (provided a procedure has been 
defined for the particular fulfillment element).

■ The Connection Manager interacts with fulfillment element connections 
through adapters. 

Adapter Usage
The following table lists the ways that the Service Delivery Platform uses adapters, 
and describes each:
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Table 1-3  Usage of Adapters

1.1.9 Adapter Commands

Adapter Types
The following table lists the types of adapters that are used and describes each:

Usage Description

Provisioning Mode ■ Usual mode of operation

■ Required mode for executing a fulfillment action or 
fulfillment procedure.

■ Only one fulfillment action or fulfillment procedure can 
be processed using an adapter.

■ An adapter using this mode can service only one request 
at a time.

Messaging Mode ■ The available message types are File and FTP (File 
Transfer Protocol).

■ These adapters send and receive messages.

■ An adapter using this mode can service multiple requests 
from multiple sources at any given time.

Test Mode ■ Used for synchronous Fulfillment of services.

■ Used for the Synchronous order type processing.

■ A fulfillment action can use only one adapter at a time.

Order Resubmission ■ Used for Processing fulfillment Actions submitted 
through the Order Resubmission Utility"
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Table 1-4  Types of Adapters

You can issue commands to Adapters in one of the following ways.

■ You pre-define a sequence of commands (through the Connection Manager) for 
the system to perform automatically during the course of the Service 
Fulfillment Manager process. This method is the most common way of issuing 
commands to the adapters.

■ You issue adapter commands manually, also through the Connection Manager. 
However, while possible, this is not recommended.

■ You schedule commands to run at a future time, or times.

You request, or schedule a request, that an adapter perform one of the following 
operations:

■ Suspend

■ Resume

■ Disconnect

■ Connect

■ Shut Down

Adapter Types Description

Interactive ■ Simulates a Telnet, FTP, or any other type of interactive 
session.

■ Requires a connection procedure.

Script ■ Executes items, such as UNIX command line scripts, 
shell scripts, or similar executables. The scripts can be of 
any type, including JavaScript by C, Java executables.

■ Does not require a connection procedure.

File ■ Used to build an XML file and to upload the file via FTP 
client to a remote fulfillment element type. 

■ Can be used to process batch file commands, if the 
fulfillment element requires this procedure

HTTP ■ Communicates directly to a web application server such 
as WAP server using the HTTP protocol. 

■ Can be used whenever the fulfillment element supports 
an HTTP protocol.
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■ Startup

The following table identifies the available commands that the Service Fulfillment 
Manager system sends to an adapter, the state that the adapter must be in to accept 
that command, and the state of the adapter after the command is implemented.

Table 1-5  Services Fulfillment Manager available commands sends to adapters

Suspend
This command stops the application from sending orders to be fulfilled. It places 
service orders in a queue until the fulfillment element becomes available.

If this command is used, then the following events occur:

■ The application will not send any data/commands/Service Order Requests to 
the connected fulfillment element. 

■ All service order requests that specify this adapter are stored in a job queue 
until the adapter is RESUMED.

The current status of the adapter must be Running for this command to be 
available.

Resume
This command acts as a toggle to resume normal operations from a previous 
suspension. 

If this command is used, then the following events occur:

Operation Current State Next State

Suspend Running Suspended

Resume Suspended Running, In Use

Disconnect Running Disconnected

Connect Disconnected Running, In Use, Error

Shutdown In Use, Running, 
Suspended, Disconnect, 
Session Lost

Shutdown

Startup ,Shutdown Starting, Running, In Use, Error, 
Shutdown
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■ The Connection Manager sets any fulfillment element interfacing to this adapter 
to either Running or In Use. 

– It sets the fulfillment element to Running, if the job queue is empty for the 
adapter interfacing at the fulfillment element (meaning that no service 
order requests awaiting Service Fulfillment Manager use this adapter).

– It set the fulfillment element to In Use, if there is a service order request in 
the Service Fulfillment Manager queue that uses the adapter interfacing to 
the fulfillment element.

The current status of the adapter must be Suspended for this command to be 
available.

Disconnect
This command is used to close the appropriate connection. All service order 
requests are queued until the adapter is available again. 

If this command is used, then the following events occur:

■ The Connection Manager sets the adapter status to Disconnected.

■ The Connection Manager places all service order requests that use this adapter 
into a queue until the adapter is re-connected.

The current status of the adapter must be Suspended or Idle for this command to be 
available.

Connect
This command is used to establish a connection to a fulfillment element so that is 
starts, or continues, its normal operation. Service order requests that are stored in a 
job queue re-start processing. 

If this command is used, then the following events occur:

■ The Connection Manager sets the fulfillment element to one of the following 
states:

– Running

– In Use

– Error

■ Processing continues based on the following conditions:
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– If service order requests are waiting in the job queue, the next service order 
request due for processing continues its Service Fulfillment Manager 
course. The status of the adapter is Busy.

– If the job queue is empty for that fulfillment element (meaning no service 
order requests are awaiting Service Fulfillment Manager), the status of the 
adapter is set to Idle.

– If the Network Element Manager status is Error, then the connection could 
not be established to the Network Element, the connection procedure failed.

The current status of the adapter must be Disconnected for this command to be 
available.

Shut Down

This command is used to close the connection to a fulfillment element by 
discontinuing adapter operation. Service order requests are stored in a job queue 
until a new adapter becomes available. 

If this command is used, then the following events occur:

■ The Connection Manager sets the adapter status to Shutdown.

■ The Connection Manager shuts down the adapter.

The current status of the adapter can not be Shutdown or Reconnecting for this 
command to be available. If the status is Busy, the shut down operation does not 
happen immediately. The application logs a Shutdown request that becomes active 
upon order completion.

Start Up
When a start up command is issued the next state is "starting". Then the next state 
can be:

■ Disconnected - If there is a problem with the connect procedure the Connect on 
demand flag on the adapter is enabled and there are no waiting orders to be 
processed.

■ In Use - If there are waiting orders to be processes.

■ Running - If there are no waiting orders to be processed and the Connect on 
demand flag is not Set.
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1.1.10 Adapter Modes
There are two types of adapters modes. They are:

■ Startup Mode

■ Debug Mode

Startup Mode
There are two possible states to the Startup Mode:

■ Automatic

The adapters can be started from the command line using the xdp-ctl utility.

■ Manual

The adapters can be started only through the Connection Manager.

Debug Mode
To allow debug messages in all layers of the Apps code to be funnelled into a single 
repository, and dynamically enabled by user.

Note: Please find more details in 
http://www-apps.us.oracle.com/atg/plans/r1152/aflog.txt

1.1.11 Adapter Schedules
You issue requests (commands) to the adapters and schedule adapter activities 
through the Connection Manager.

Adapter Commands
You issue the following commands to adapters:

■ Connect: Establish a connection to the fulfillment element and resume its 
normal operation. 

■ Disconnect: Close the appropriate connection and store the service activation 
order in a job queue until the connection to the fulfillment element is restored 
by issuing a connect request.

■ Ftp file: Transfer a file using ftp.

■ Resume: Resume normal operation. 

■ Shut down: Close the connection to the fulfillment element by bringing down 
the adapter.
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■ Start up: Start up a new adapter and establish a connection to the fulfillment 
element (if any).

■ Suspend: Stop Oracle Service Fulfillment Manager from sending any orders to 
be provisioned and have all service orders placed in a queue until the 
fulfillment element becomes available.

 Adapter Scheduling
You schedule the use of adapters in one of three ways:

■ Immediate: The adapter fulfills the request immediately, on the current date.

■ Future: The adapter fulfills the request on a future date.

■ Periodic: The adapter fulfills the request at periodic time intervals based on the 
supplied period.

.The Connection Manager

The Connection Manager provides the means to view, quickly modify, and manage 
the adapters connected to each fulfillment element. Adapters maintain connectivity 
to each fulfillment element during service Service Fulfillment Manager.You can 
manage each connection for purposes such as load balancing, trouble shooting and 
maintenance.

You use the Connection Manager to accomplish the following tasks:

■ View all the available fulfillment elements that have been configured in Oracle 
Service Fulfillment Manager

■ View the total number of service order requests awaiting activation in the queue 
for a selected fulfillment element

■ View the average time a service order request has been waiting in the queue

■ View the number of adapters currently active for this fulfillment element

■ View the date and time when the order entered the queue

■ View the elapsed time a service order request has been in the queue

■ View network problems and order flow to perform trouble shooting

■ Monitor the number of adapters currently available

■ Perform administrative activities on adapters

■ Schedule activities for adapters
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1.1.12 Fulfillment Element Types in Oracle Service Fulfillment Manager

Fulfillment elements in Oracle Service Fulfillment Manager are grouped into logical 
categories. A fulfillment element type can be any of the following:

■ An operating system

■ An equipment platform

■ A Network Element Mediation (NEM) layer

■ A piece of telecommunication-specific hardware

The table following lists examples of different fulfillment element types.

Table 1-6  Example of different fulfillment element types

Parts to a Fulfillment Element Type
Any service order request provisioned through Oracle Service Fulfillment Manager 
requires that the type for that specific fulfillment element be defined in the system 
before the fulfillment element itself is defined.

To configure a fulfillment element type, you must define the following items:

■ The fulfillment element type name and details

■ The software generic properties for the fulfillment element type

Note: Fulfillment element types are defined by system experts 
only.

Item Fulfillment Element Type

Home Location 
Registration (HLR) unit

Network Element

Cisco server Server

AT&T 5ESS switch Telephony Switch

Nortel DMS200 switch Telephony Switch
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■ The attributes of the fulfillment element type

Type Attributes
An attribute defines a property of a fulfillment element type. This can include all of 
the attributes with a connect/disconnect procedure. Attributes are also used to 
uniquely identify a fulfillment element. 

Each fulfillment element inherits its attributes from its fulfillment element type. The 
value of an attribute is the default value defined at the level of the fulfillment 
element.

The attributes of an fulfillment element type defines its properties and behavior. 
These include the following:

■ IP address

■ Username

The following are additional attributes for a fulfillment element type:

■ Passwords used in connection/disconnection procedures

■ Software generics associated with the procedures

All attributes are associated with a fulfillment element type or a fulfillment element.

■ Each fulfillment element instance can have a different value. 

■ Each fulfillment element inherits attributes from its fulfillment element type.

■ Adding attributes is performed at the fulfillment element type level. 

Fulfillment Element Type Attribute Default Values
Oracle Service Fulfillment Manager sets default values for the following attributes:

Note: It is possible to configure multiple software versions (generics) for 
each fulfillment element type, each with a specific effective date.

WARNING: Setting a value for an attribute overwrites the 
default value of that attribute specified at the fulfillment element 
type level.
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NE_CMD_TIMEOUT
When executing commands within a fulfillment element, the default set time-out is 
120 seconds.

NE_CMD_RETRY
The adapter retries the command numerous times before it times- out. A failure 
message is returned and the default value is set to zero retry.

NE_CMD_WAIT
Waiting period (in seconds) before retrying commands within a fulfillment element. 
The default value is set to zero seconds.

NE_NO_ACTIVITY_TIMEOUT
Some fulfillment elements may terminate the session, if there is no processing 
activity. The Service Delivery Platform allows you to set processing time to execute 
a command. This allows the connection between an adapter and the fulfillment 
element to remain active. The default processing time is set to 120 seconds.

NE_DUMMY_CMD
The Service Delivery Platform allows you to send commands to a fulfillment 
element to maintain the active sessions with the adapter. The adapter sends a 
command five seconds before processing time-out (NE_NO_ACTIVITY_
TIMEOUT). 

NE_CONNECT_RETRY_COUNT
Number of times the interactive adapter will try to reconnect automatically if the 
connection to the fulfillment element is dropped. The default value is zero.

NE_CONNECT_WAIT
Elapsed time (in seconds) between attempts to reconnect. The Default value is zero.

1.1.13 Fulfillment Elements in Oracle Service Fulfillment Manager
In the Oracle Service Fulfillment Manager, a fulfillment element is a unique 
physical entity. It has the following characteristics:

Note: If you want an carriage return command to be sent, use " " 
as the attribute value. The default command is " ".
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■ It has a unique name on a carrier’s network.

■ It is a member of a unique Fulfillment Element type.

You must give each fulfillment element a unique name. This name is registered in 
the system during the configuration of the fulfillment element. 

For example, if a telecommunications service provider has a router of a certain 
fulfillment element type (such as Cisco), then a logical name (Cisco_LA, or Cisco_
NY, etc.) must be created for it during configuration. This helps to identify which 
particular Cisco router needs to be activated during Service Fulfillment Manager.
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1.1.14 Standard Function Activities Provided by Oracle Number Portability
You receive the following number portability standard function activities with the 
application:

Table 1-7  Number Portability standard funtion activities

Name Description

Check Flag Value Checks the flag value for the given PORTING_ID workitem 
parameter.

Check if Donor is 
eligible to Port Out

Checks whether or not the donor service provider in this porting 
transaction has provisioned the number range, or has assigned 
the number range.

 If either condition is true, then the activity completes with Y.

Check if Donor is Initial 
Donor

Checks whether or not this donor is also the initial donor.

Create or Modify SMS 
Porting Records

Creates or modifies a Porting Record for each telephone number 
in the range. The Porting ID for the first record is the same as that 
set in the work item parameter.

Create Porting Order Creates a porting order based on the Service Provider role.

Deprovision FEs Sets the fulfillment elements to be deprovisioned for this feature 
type and number range. For each fulfillment element, the Oracle 
Service Fulfillment Manager provisioning procedure (Execute 
FA) is invoked.

At the end of this activity, control passes to the provisioning 
subsystem which executes the fulfillment procedure. An FA_
DONE message is subscribed for each fulfillment action being 
executed which gives the execution result of the fulfillment 
procedure. The callback procedure associated with the FA_DONE 
handles the responses received.

The immediate next activity following this activity must be the 
Oracle Service Fulfillment Manager Standard Wait For Flow. This 
is to ensure proper hand-off from the provisioning system back to 
the Number Portability system.

Only fulfillment elements that were earlier provisioned by this 
service provider can be modified. Otherwise, the fulfillment 
elements are ignored.

Determine Current 
Service Provider Role

Determines whether or not a given service provider is the donor, 
original donor, or recipient for the current porting transaction, 
and completes the activity with the appropriate result code.
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Determine if Subsequent 
Porting Request

Checks whether or not this is a subsequent porting request.

Returns either Y or N.

Does Porting Record 
exist for Donor

Check whether or not there exists a porting record with the given 
status in this telephone number range that belongs to the given 
donor’s service provider ID.

Returns either Y or N.

Does Porting Record 
exist for Recipient

Check whether or not a porting record with the given status 
exists in this telephone number range that belongs to the given 
recipient’s service provider ID.

Returns either Y or N.

Get Porting Status Retrieves the status of the porting record for the given PortingID

Prepare Notification 
Message

Prepares a default notification message.

Provision or Modify 
Provisioned FEs

Sets or retrieves the fulfillment elements to be provisioned or 
modified for this feature type and number range. For each 
fulfillment element, the Service Delivery Platform’s provisioning 
procedure (Execute FA) is invoked.

At the end of this activity, control passes to the provisioning 
subsystem which executes the fulfillment procedure. An FA_
DONE message is subscribed for each fulfillment action being 
executed which gives the execution result of the fulfillment 
procedure. The callback procedure associated with the FA_DONE 
handles the responses received.

The immediate next activity following the activity must be SDP 
Standard Wait For Flow. This is to ensure proper hand-off from 
the provisioning system back to the Number Portability system.

Only fulfillment elements that were earlier provisioned by this 
service provider can be modified.

Set Date Value Sets the Date value

Set Flag Value Sets the flag to the given value for the entries in XNP_SV_SOA 
for the given PORTING_ID workitem parameter, and FLAG_
NAME for the current Service Provider.

The Value is 'Y' or 'N’.

Set SMS Provisioning 
Done Date

Sets the date when the Service Management System completes 
provisioning

Name Description
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Update Charging 
Information

Updates the Subscription Version in the Service Order 
Administrator for each telephone number with the given Porting 
ID, with invoice information.

Update Comments and 
Notes Information

Updates the comments and notes for the current Porting ID and 
the current service provider.

Update Customer 
Information

Updates the customer information for the current Porting ID and 
the current service provider.

Update Network 
Information in SOA

Updates the network information in the XNP_SV_SOA for the 
current Porting ID and the current service provider.

Update Porting Status 
for Number Range

Updates the status type code in the XNP_SV_SOA with the new 
status type code. All records with the porting ID belonging to the 
current service provider are updated to the new status.

If the new status belongs to the ACTIVE phase, and if records 
exist for this number range in ACTIVE phase, then these records 
are first reset to the OLD phase. The actual update of the records 
with the given porting ID is performed after this step.

Update Porting Status 
for Porting Id

Updates the status type code in the XNP_SV_SOA with the new 
status type code. All records with the porting id and belonging to 
the current service provider are updated to the new status. If the 
new status belongs to the ACTIVE phase, and if there exists 
records for this number range already in ACTIVE phase, then 
they first are reset to OLD phase. The actual update of the records 
with the given porting id is done next.

Validate Runtime Data Validates runtime data

Verify Porting Status Checks if the STATUS_TYPE_CODE from XNP_SV_SOA for the 
given PORTING_ID is same as the given status type code (in 
STATUS_TO_COMPARE_WITH).

 Returns T if the two statuses match.

 Returns F if the two statuses do not match.

Name Description
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Definition Considerations
When configuring a fulfillment element, consider the following:

■ A fulfillment element is always configured as an instance of a fulfillment 
element type.

■ Attributes assigned to a fulfillment element type are inherited by the newly 
configured fulfillment element.

■ Attribute values can be overwritten at the fulfillment element  level.

Services
In Oracle Service Fulfillment Manager, a service is a telecommunication-related 
product, offered to the customer as an individual item or in bundles.

Examples of services include:

■ Telephone services: Voice, data, videoconferencing, FAX, etc.

■ Internet Protocol (IP) services: Web hosting, ecommerce, email, etc.

1.1.15 Work Items in Oracle Service Fulfillment Manager
Services provided by the carrier are fulfilled by a set of work items performed in a 
specific sequence within Oracle Service Fulfillment Manager. A work item, then, is a 
unit of work which is necessary to fulfil a service action. 

■ You assign to a work item the appropriate parameters, fulfillment actions and 
fulfillment procedures necessary for the Service Fulfillment Manager process. 

■ Fulfillment actions are responsible for the actual Service Fulfillment Manager of 
services at the fulfillment element level. 

■ As an alternative to work items, users can execute the fulfillment actions 
conditionally in a user-defined workflow. The workflow is defined according to 
pre-set conditions in a service order request.

Predefined Work Items in Oracle Number Portability
Work items are organized into groups known as item types. The following table lists 
the standard item types delivered with Oracle Number Portability.
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Table 1-8  Oracle Number Portability standard item types

Note: Do not modify any of the standard Oracle Number 
Portability item types, except NP Processes.

Item Type Internal Name Description Customizable

Standard WFSTD Contains standard function activities that 
are commonly used to create business 
processes.

No

SFM 
Standard

XDPWFSTD Contains function activities that are 
commonly used across both the Oracle 
Service Fulfillment Manager and Oracle 
Number Portability applications.

The following are examples of functions:

■ Send Message

■ Subscribe to Acknowledgments

No

SFM 
Lookup 
Code

XDPCODES Contains lookup types used for easy 
selection in workflow activities. This could 
be, for example, a list of fulfillment 
actions, or a list of messages.

No

NP 
Standard

XNPWFSTD Contains function activities that are 
specific to Oracle Number Portability. Use 
these activities in the implementation of 
your business processes.

The following are examples of standard 
functions:

■ Creating a porting order

■ Determining if porting is possible

No

NP Lookup 
Code

XNPTYPES Contains lookup types used for easy 
selection in workflow activities. This could 
be, for example, a list of fulfillment 
actions, or a list of messages.

No
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Guidelines
4. In general, you should use the SFM Standard and NP Standard function 

activities whenever possible, and only customize the Number Portability 
activities as absolutely necessary.

5. SFM Lookups and NP Lookups must be updated as you start to configure 
Oracle Service Fulfillment Manager. Run the Lookups Loader API to update 
these item types.

Work item Types
The available work item types are:

■ Static: The list of fulfillment actions and their sequence are defined prior to 
runtime and do not change.

■ Dynamic: The list of fulfillment actions and their sequence are determined at 
runtime by executing a shared procedure.

■ User-defined workflow: The list of fulfillment actions and their sequence are 
determined at runtime by a predefined workflow that executes multiple 
procedures based on some pre-defined conditions.

■ User workflow procedure: Sets the user-defined workflow that is to execute at 
runtime.

1.1.16 Packages
A service package contains at least two products/services which are sold together 
as a unit. 

■ A package may consist of either related or non-related services. 

■ All attributes and rules that apply to a service also apply to a service package. 

■ A service package must contain at least two mandatory products before it can 
be made available to customers. It can contain as many optional services as 
desired.

The dates of availability for the service package and the services/products within 
the package must be consistent. For example, you can not set the package available 
start date earlier than the earliest start date of all products in the package.

It is possible to add products/services to the package version. However, mutually 
exclusive products cannot be added to a package. In addition, products with 
dependencies (co-requisites) can not be added to a package unless the entire set is 
added.
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During package creation, you must specify the minimum and maximum number of 
products the customer can order from a package that has optional products. For 
example, you may require that a customer pick at least three, but no more than five 
of eight possible services/products in the package.

1.1.17 Notifications
The Notifications module is a utility which provides a graphical interface for 
monitoring service request orders that fail during Service Fulfillment Manager. 

If a service order request fails, then the Service Fulfillment Manager workflow 
sends notifications about these failed service order requests to the Notifications 
utility, reporting Service Fulfillment Manager problems at various phases of the 
Service Fulfillment Manager process. 

Users with sufficient privilege can review and correct the failed orders through 
manual intervention. The privileged user can, for example, perform the following 
tasks from within the Notifications utility:

■ View order flowthrough.

■ View workflow notifications for failed service order requests.

■ Respond to a notification by assigning an error handling action to the service 
order request.

■ Forward a notification to appropriate individuals or groups for resolution.

■ Modify the service order request.

■ View the workflow diagrams of order activities, using the Workflow Monitor.

If more details are necessary to asses the problem and resolve a failure, the 
privileged user can step through each of the failed notifications and view the actual 
Service Fulfillment Manager commands sent by a particular service order request to 
a fulfillment element and the responses to those commands.

Based on the information contained in the notification messages received in the 
Notifications utility, the privileged user can follow-up with service order requests 
or workflow that failed during the Service Fulfillment Manager process. 

Note: Once a product package has been defined and in the 
available state, it is not possible to modify or change the package. 
You must create a new version of the package to modify that 
package in any way.
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Follow-up actions include the following:

■ Sending the order/workflow back to the process after modifying the order

■ Sending orders to other personnel for escalation or resolution

■ Stopping the process altogether

The Notifications Utility
You view and access workflow notification messages through the Notifications 
utility. 

You can view:

■ All messages (both open and closed)

■ Only the open notification messages.

You can query messages based on the following criteria:

■ Status

■ Receive date

■ Order number

■ Notification Type

1.1.18 Messaging in Oracle Service Fulfillment Manager
Oracle Service Fulfillment Manager obtains messages which are initiated from 
workflows to communicate with external systems. A message can be used to initiate 
a Start Billing event with a billing system. Workflow can be configured to wait for 
inbound messages or can branch out to another workflow based on the information 
passed.

Message functions
The following are messages functions:

■ Trigger a process

■ Activate processes within an application

■ Send application messages asynchronously using the Event Manager

Note: You can only search for orders which have their workflow 
started.
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■ Receive application messages asynchronously using the Event Manager

■ Handle incoming and outgoing messages and events using multiple queues 
and the Event Manager

Message Definition
The following are ways to define a message:

■ Message type: The message type defines a message either as a timer, an event, 
or a message.

– Messages are used for communication between application systems. 

– Events are used to broadcast multi-cast state changes in business objects. 
Events are published to both external and internal application systems.

– Timers are messages that have a time delay and a duration interval 
associated with them.

■ Message for internal applications: Internal applications can register a PL/SQL 
callback procedure via the Event Publisher or through an API.

■ Messages for external applications: External applications do not register 
callback procedures, but have adapters that relay the published event to the 
remote system. External applications can register for an event using the default 
subscribers screen.

Message Queues
Messages can go to multiple queues. The following are some of the queues where 
messages can reside:

■ Inbound Message Queue: Messages are sent to this queue for internal 
processing.

■ Outbound Message Queue: Messages are sent to this queue that are enroute to 
peer systems.

■ Internal Event Queue: Messages defined as Events ignore the queue name and 
the event is published to both the Outbound Message Queue and the Internal 
Event Queue.
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The table following lists the messaging queues and their attributes.

Table 1-9  Messaging Queues and Attributes

Outbound Message Structure
Outbound messages must have the following defined:

■ Subscriber (system)

■ Gateway name

■ Adapter type

Message Elements
Message elements in the message Studio can be marked either as mandatory or 
optional.

During message creation, the iMessage Studio automatically inserts the Message 
Code and MESSAGE as mandatory message elements in the Elements screen. In 
addition, the message code is defined as the root element. However, it is possible to 
define an element more than once in the structure. 

Follow these guidelines during message creation:

■ Message element names must follow PL/SQL naming conventions.

■ The internal name for all message elements must be defined in upper case, 
replacing any spaces with an underscore. 

Queue Name Service Name Description

Inbound Message Queue Message Server Processes all incoming messages.

Internal Events Queue Event Server Events generated for internal 
consumption are enqueued on the 
internal events queue for speedy 
processing.

Outbound Message Queue Communication 
Adapters

Dequeues messages from the 
Outbound Message queue and 
passes it to the peer system.
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■ Message elements marked as parameters automatically use the default value 
specified.

■ Message elements marked as parameters are used to derive values of remaining 
message elements.

■ Message elements marked as parameters are not passed in the content of the 
message body.

■ Message elements marked as parameters generate CREATE_MSG(), SEND() 
and PUBLISH() procedures with the specified message element as a parameter 
defaulted to the message specified. 

Mandatory Elements
■ Message elements can be marked as mandatory or optional.

■ Upon receiving an incoming message, the validation logic checks all mandatory 
message elements to ensure that values are in the correct data format.

Message Processing Logic
The Oracle Service Fulfillment Manager Event Manager handles all incoming 
messages and events. There are four possible ways to process a message. The table 
following lists them.

Warning: Never delete the root element of a message.

Table 1-10  Message Processing Logic Types

Type Process Description

Default Process Logic DEFAULT_PROCESS() Automatically executed by the Event Manager if no 
application has registered for the message.
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Processing Failure
The Event Manager does not deliver a message to any registered applications if an 
error is detected during the execution of the processing logic. Nor does the Event 
Manager process and deliver a message if the message validation process failed. If 
an error occurs, each resulting error code and error message are logged into the 
system log.

Message Processing Logic - Guidelines
Use the following guidelines during creation of your message processing logic 
procedures.

1. If no application logic is specified, the procedure is created with a single NULL; 
statement

2. Any user defined data which is stored as part of the registration process is 
passed to the procedure in the parameter p_process_reference.

3. The parameter p_msg_text is the XML message

4. Element values can be obtained using the following procedure: 

xnp_xml_utils.decode(). xnp_xml_utils.decode

This procedure works only if a message has no repeating elements.

Validate Logic VALIDATE() Automatically executed by the Event Manager on the 
newly arrived messages. 

The VALIDATE() procedure provides a hook to include 
business specific validation.

Incoming Message Process 
Logic

PROCESS() Executed by the Event manager before delivering the 
message to the callback procedure of the registered 
application. 

The PROCESS() procedure also provides a hook to 
include any application logic.

Outgoing Message Process 
Logic

 SEND() Executed by the Event Manager before publishing a 
message to the Outgoing Queue for delivery. 

These logic procedures are not generated automatically, 
they are user-defined and the code is executed as part of 
the SEND() procedure. 

Table 1-10  Message Processing Logic Types

Type Process Description
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5. User defined logic is required to return any error code and error message. This 
information must be passed using the parameters:

■ x_error_code 

■ x_error_message 

6. Any non zero value in x_error_code is considered to be an error.

Timer Types
Oracle Provisioning comes with three different timer types. The table following 
describes each type.

Table 1-11  Timer Type and Description

Timer Elements
Timer messages requires two mandatory elements: 

■ Delay

■ Interval

Additional optional elements can also be related to a product type, customer 
category, or the service level agreement based on the business requirements of the 
user. 

Timer Data
It is possible to set the delay and interval timer elements in several different ways:

■ The user provides the data source for the timer elements. This feature is useful 
in retrieving the timer information from other timer configuration tables. 

■ A stored procedure retrieves the timer delay and interval information. 

Timer Type Description

Activity Timer The timer is associated with a particular activity within a 
workflow.

Process Timer The timer is associated with an entire workflow process.

Message Timer  The timer is associated with a message.
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If desired, you can also set the processing logic that occurs when the timer expires. 
The processing logic may include jeopardy management or error processing 
features when the timer expires. 

Event for Timer or Message Acknowledgment
The Waiting For Acknowledgments activity subscribes to events. An event may be 
configured to include and Acknowledgment for the Message sent out and a Timer. 
Depending on the message received, the workflow progresses.

For example.,

We may have an event group call MSG_ACK_TIMER_1 that consists of Timer 1 and 
Ack. Depending on Timer 1 or Ack being received, the workflow progresses.

Timer Testing 
■ You may also specify that a test message be sent to test that the Timer message 

has been correctly configured.Define a connection management schedule as 
needed
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1.1.19 Using the Flowthrough Manager
It is possible to view status details and other details of a service order while it is in 
one of the following phases:

■ Ordering

■ Active

■ Old

To view the porting summary, perform the following steps.

Prerequisites
None

Steps
1. In the Navigator, choose Operations > Flowthrough Manager.

If an order has not yet been referenced, the Find Orders dialog box displays 
initially.

2. Enter a value to use as the search criteria in the Find Orders dialog box. 

You can search for an order on several criteria. If you know the order ID or 
order number, then simply enter this information and click Show Order. 
Alternatively, you can enter one or more of the other criteria to search for the 
order.

The Flowthrough Manager displays the found order (with the order number in 
the left-hand list box). All of the line items associated with this order are 
displayed in the form of leaf nodes. If necessary, expand the list of line items by 
clicking the plus sign next to the order number.

3. Select the Order Header tab to view the basic information associated with this 
order. 

The current Service Fulfillment Manager status of the order displays in the 
Order Status field.  Service Fulfillment Manager  statuses are pre-seeded by the 
application.

To view information about the Notifications, Event Log, Workflow and 
Parameters associated with this order, click the appropriate button at the 
bottom of the screen.
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4. Select the Order Line tab to view information relating to the current Service 
Fulfillment Manager status and associated parameters for this order. 

■ To view information about the workflow associated with this order, click 
Workflow.

■ To view information about the parameters associated with the order line, 
click Parameters.

5. Select the Work Items tab shows all the Work Items associated with the selected 
Order Line Item selected on the left hand corner (the leaf element).

■ To view status and state information, select the Status sub-tab.

■ To view date-related information, select the Date sub-tab.

■ To view information about the parameters associated with a work item, 
select it and click Parameters.

■ To view information about the workflow associated with this work item, 
click Workflow.

6. Select the Fulfillment Actions tab to view information relating to fulfillment 
actions associated with this work item and the fulfillment element to which 
each action is being applied.

■ To view status-related information, select the Status sub-tab.

■ To view date-related information, select the Date sub-tab.

■ To view Parameter, Audit Trail, and Workflow information for a fulfillment 
action, select a fulfillment action (if any exist for this order) and click the 
appropriate button at the bottom of the screen.

7. Click Cancel to exit the Order Flowthrough screen.

1.1.20 Managing Notifications
From the Notification Inbox, you can take various actions to deal with workflow 
notification. For example, you can perform the following tasks:

■ Viewing notifications

■ Adding comments to a notification message

■ Responding to a message notification

■ Forwarding a message notification
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Viewing Notifications
To view the existing notification messages in the system, perform the following 
steps.

Prerequisites
None

Steps
1. In the Navigator, choose Operations > Notifications.

2. Click View Open to view only those notification messages that are currently 
open.

3. Click View All to view notification messages, regardless of status.

4. Select a notification from the list at the left.

The Notification Message Details window opens.

5. Close the window after viewing the information.

Adding Comments to a Notification Message
To add a comment to a notification message, perform the following steps.

Prerequisites
The message must exist for this option to be available.

Steps
1. In the Navigator, choose Operations > Notifications.

2. Select a notification from the list at the left.

3. Click View Details.

The Notification Message Details window opens.

4. Click Add Comment to launch the Notification Comment window. 

5. Enter your comments about the notification in the space provided. 

6. Close the window.

7. Save your changes.
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Responding to a Notification Message
To respond to a notification message, perform the following steps. Responding to a 
notification changes its status from Open to Closed.

Prerequisites
The status of the message must be Open for this option to be available.

Steps
1. In the Navigator, choose Operations > Notifications.

2. Select a notification from the list at the left.

3. Click View Details.

The Notification Message Details window opens.

4. Click Respond to launch the Notification Response window.

5. Select one of the responses from the drop down menu.

6. Click OK to close the window and initiate the action.

Forwarding a Message Notification
To forward the notification to a third party, perform the following steps.

Prerequisites
The status of the message must be Open for this option to be available.

Steps
1. In the Navigator, choose Operations > Notifications.

2. Select a notification from the list at the left.

3. Click View Details.

The Notification Message Details window opens.

4. Click Forward to launch the Notification Response window. 

5. Select another user or group from the drop-down menu.

6. Click OK to close the window and reassign the message. 
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1.1.21 Resubmitting an Order
You use the Resubmission Utility to re-run orders. This is useful, for example, if a 
network switch fails, or experiences service disruption that causes a Service 
Fulfillment Manager order to fail. The order, however, has not been lost by the 
system, and can be resubmitted when the unit becomes available.

For example, a particular fulfillment element fails at 3:02 a.m. on a particular date. It 
remains unavailable for service until 5:20 a.m. the same day. This fulfillment 
element was to be used to provision a number of orders during that span of time, 
but as it was unavailable, the orders failed to complete. After the fulfillment 
element (or its replacement) becomes available, it is necessary to resubmit all orders 
that were to be provisioned by that particular fulfillment element during the 
window of time from 3:02 to 5:20 a.m. The order information is not lost, and can be 
re-used to resubmit the original Service Fulfillment Manager orders.

You use the Resubmission Utility to perform the following tasks.

■ Creating a new resubmission job

■ Verifying the status of a resubmission job

Creating a New Resubmission Job
To resubmit all orders that were to be provisioned by a specific fulfillment element 
during a span of time, perform the following steps.

Prerequisites
None

Steps
1. In the Navigator, choose Operations > Order Resubmission.

The Order Resubmission Jobs form window opens. Previously defined 
resubmission jobs display under Job ID (Fulfillment Element) at the left-hand 
side of the screen.

2. Click New.

Note: When a notification is reassigned, it is marked as Closed.
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The New Job Window opens. You use this window to create a new 
resubmission job that targets a specific fulfillment element during a specified 
time window.
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3. Enter the name of the fulfillment element for which you wish to resubmit 
orders. 

Chose a fulfillment element from the List of Values (LOVs). 

4. Enter the exact date and time at which the fulfillment element became 
unavailable in the Outage Start Date field. And, if desired, enter the exact date 
and time that the fulfillment element became available again.

5. Enter the number of adapters that this affects in the No. of Adapter field.

6. Click Submit.

The job displays in the Job ID (Fulfillment Element) window. You can track the 
progress of order resubmission process through the Job ID.

7. Click Cancel to close this window.

Verifying the Status of a Resubmission Job
To view the status or details of a resubmission job, perform the following steps.

Prerequisites
None

Steps
1. In the Navigator, choose Operations > Order Resubmission.

The Order Resubmission Jobs form window opens. Previously defined 
resubmission jobs display under Job ID (Fulfillment Element) at the left-hand 
side of the screen.

2. Select the Job ID from the list at the left.

The pertinent information for the resubmission job displays.

3. Click Order List.

The Resubmitted Order Information window opens. This window displays 
information about each individual order. 

4. Click Cancel to close the Resubmitted Order Information window.

5. Click Cancel to close the Order Resubmission Jobs window.
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1.1.22 Managing the System Queues  
You perform a number of tasks with system queues. These include:

■ Viewing summary information about queues

■ Finding an order in the queue

■ Starting up a queue

■ Shutting down a queue

■ Suspending a queue

■ Resuming queue operation

■ Viewing XML messages

Viewing Summary Information about Queues
The Queue Console displays the following summary information about all of the 
system queues.

■ State (Enabled, Shutdown, Suspended)

■ Number of entries in the queue

■ Date that the last entry in the queue occurred

■ Number of dequeue processors that are registered

■ Number of processors that are currently running for the queue

 To display this information, perform the following steps.

Prerequisites
None

Steps
1. In the Navigator, choose Administration > Queue Console.

The Queue Console opens.

2. Select a queue.

The View Details button is enabled if there are entries in the queue, otherwise it 
is grayed out.
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3. Click View Details to view additional information about the entries in a queue.

A window opens that displays the entries for the queue.

4. Close this window and return to the Queue Console by clicking the X in the 
upper right-hand corner of the window.

Finding an Order in the Queue
To search for an order that is currently in the queue, perform the following steps.

Prerequisites
None

Steps
1. In the Navigator, choose Administration > Queue Console.

The Queue Console opens.

2. Select a queue.

The View Details button is enabled if there are entries in the queue, otherwise it 
is grayed out.

3. Click View Details.

A window opens that displays the entries for the queue.

4. (Optional) Select View > Query By Example > Enter from the View menu on 
the toolbar to find a specific order in the queue, or to find entries that match a 
search criteria.

5. (Optional) Enter the search criteria in the provided fields.

6. Select View > Query By Example > Run from the View menu on the toolbar.

If one, or more records are found that match the search criteria, then the 
information displays.

7. Select View > Query By Example > Cancel from the View menu on the toolbar 
to close the window and return to the Queue Console.

Note: If there are a large number of orders in the queue, this 
action may take several seconds to complete.
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Starting Up a Queue

To start all processors of the queue, perform the following steps.

Prerequisites
The queue must be in Shutdown mode for this option to be available.Steps

1. In the Navigator, choose Administration > Queue Console.

The Queue Console opens.

2. Select a queue.

If the queue is in Shutdown mode, the Startup button is enabled.

3. Click Startup. 

The Queue Status changes to Enabled.

Shutting Down a Queue

To shut down all processors of the queue, perform the following steps.

Prerequisites
The queue must be in either the Enabled or Disabled mode for this option to be 
available.

Steps
1. In the Navigator, choose Administration > Queue Console.

The Queue Console opens.

2. Select a queue that is either in the Enabled or the Disabled mode.

3. Click Shutdown. 

The Queue Status changes to Shutdown.

Suspending a Queue

To suspend processing of orders in the queue, perform the following steps.

Prerequisites
The queue must be in either the Enabled or Disabled mode for this option to be 
available.
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Steps
1. In the Navigator, choose Administration > Queue Console.

The Queue Console opens.

2. Select a queue that is either in the Enabled or the Shutdown mode.

If the queue is in Enabled or Shutdown mode, the Suspend button is enabled.

3. Click Suspend. 

The Queue Status changes to Disabled.

Resuming Queue Operation

To resume processing orders in the queue, perform the following steps.

Prerequisites
The queue must be in the Disabled mode for this option to be available.

Steps
1. In the Navigator, choose Administration > Queue Console.

The Queue Console opens.

2. Select a queue that is in the Disabled mode.

If the queue is in Disabled mode, the Resume button is enabled.

3. Click Resume. 

The Queue Status changes to Enabled.

Viewing XML Messages
To view the XML content for a message that is currently in the queue, perform the 
following steps.

Prerequisites
To view XML message content, you must select either the Outbound Messages 
queue, the Inbound Messages queue, or the Event queue, and you must have an 
XML-enabled browser available to display XML messages.
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Steps
1. In the Navigator, choose Administration > Queue Console.

The Queue Console opens.

2. Select a queue.

The View Details button is enabled if there are entries in the queue, otherwise it 
is grayed out.

3. Click View Details.

A window opens that displays the entries for the queue.

4. Select a message from the list at the left.

5. Click View XML.

If available, an XML-enabled browser window opens and displays the XML 
message. 

1.1.23 Other Considerations
In order to efficiently complete an implementation, you should do the following:

■ Provide the telecommunications service provider with a report highlighting 
your findings, conclusions and recommendations on implementations time 
frame. 

■ If any processes are not defined, escalate this as an issue for not being able to 
define properly the business process Workflow in Oracle Service Fulfillment 
Manager.

■ Present the report to the appropriate management.

■ Until you have gathered all the information and the right resources for the 
project DO NOT PROMISE A DELIVERY OF PRODUCTION READY 
SOFTWARE TO THE CUSTOMER.

■ Bring recommendations to the Customer, action items to resolve issues, 
concerns, and directions and associate the next steps.

1.1.24 Typical Release Dependencies
Oracle Service Fulfillment Manager 11i is based on the foundation of the Oracle 
installed base that includes:

■ Common Data Model
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■ Common Schema

1.1.25 Setting Up Oracle Service Fulfillment Manager

Information Gathering

Required Information
Implementations for telecommunications service providers cam be complex or 
simple. In many cases it will take simple identification of the implementation’s 
scope. 

The following needs to be identified when planning an implementation for Oracle 
Service Fulfillment Manager:

■ Number of services

■ Actions required for each service

■ Network elements needed to be provisioned for each service

■ Number of processes (to include exception handling)

■ Anticipated future items to be implemented

■ Time and resources needed to complete the project (done by Oracle Consulting)

Gathering Information
The following tasks are involved in planning an implementation for Oracle Service 
Fulfillment Manager:

Planning Information Gathering
While the direct approach (interviews with the telecommunications service 
provider) my be the primary way to gather information, do not overlook other 
methods. Some of these may be to gather information by:

■ Observing telecommunication service provider operations

■ Talking to telecommunication service provider customers

■ Interviewing the telecommunication service provider who perform the 
processes
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To help you gather information, do the following:

■ List information needed

■ Identify sources for collecting information (keeping in mind that there may be 
more than one source)

■ Correlating gathered information with appropriate processes and tasks for 
implementation and process building

Asking questions 
The following are examples of questions you can use when gathering information:

■ How is a Service Order Request captured initially? 

■ What is the data captured and where is it coming from?

■ Which schema will the data reside - in the Order Entry, in Oracle Service 
Fulfillment Manager or both? Or will the data and schema depend on certain 
parameters only?

■ Must the data be derived from external sources (e.g., outside Service Providers, 
external systems outside of SDP, etc.)? 

■ What is the syntax for each service to be activated within a Network Element?

■ How will the customer handle exceptions, errors, failures?

■ Is there a second path for activation if the first path fails, who needs to be 
updated?

Implementation Tasks
■ Form an implementation team

■ Bring resources from Oracle Consulting to help implement the project

■ Identify the Customer’s needs and submit a plan with guidelines and time 
frames for project completion

■ Submit a plan for identifying and for resolving project roadblocks 

■ Identify overall existing Customer’s business processes and the new business 
processes which will be implemented by Oracle Consulting 

■ Identify the list of telecommunication service provider’s products and services

■ List telecommunication service provider’s priorities for implementation
1-54 Oracle Service Fulfillment Manager Implementation Guide



Considerations for Planning an Implementation Project
■ Identify the overall network infrastructure for telecommunication service 
provider’s products and services.

■ Identify the number of subscribers 

■ Correlate telecommunications service provider’s products and services with 
their subscribers

■ List the issues the telecommunications service provider needs to address

■ Identify interface requirements needed for compatibility with other systems

■ Identify the incompatible systems

Sources of Information
For a successful implementation there will be numerous information items you will 
need to gather. Some of these include:

■ Collect obvious information

■ Uncover hidden information

■ Identify issues

■ List concerns 

■ Address needs

■ Determine direction (telecommunications service provider’s)

While there are many sources for information, the following telecommunications 
service provider’s department are a good start to find information items:

■ Service Service Fulfillment Manager

■ Order Processing

■ Network Management

■ Engineering

■ Information Technology 

■ Customer Service

Information Gathering Considerations
The following are items to consider when gathering information:
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■ Use the “right person” to obtain information from at the telecommunications 
service provider’s site. Do not select interviews by title. Try to find and 
interview the person closest to the operation. This may include:

– Network / Operations Engineers

– Process Engineers

– Marketing Associates

– Order Entry Analysts. 

■ Interview and debrief the telecommunications service provider’s upper 
management. This will help you determine some general corporate issues and 
keep them informed about the projects’s progress.

■ Identify the current number of products and services to be deployed by the 
telecommunications service providers.

■ List number of network elements which need to be provisioned in order to 
activated the products of services.

■ Identify future plans (growth) for products, services, facilities, and network 
elements.

■ Verify syntax /commands that are used to provision each service within a 
network element.

■ List the actions needed for each product, services, and network elements.

■ Identify the number of activation procedures to be written for new product and 
service Service Fulfillment Manager.

■ Identify the number of Workflow (business processes and exception handlings) 
to be written.

1.1.26 Service Fulfillment Manager Activities Planning
The user should be able to define business rules in the following PL/SQL 
procedures for the selection of work item to execute for a given service, the selection 
of fulfillment actions to execute for a given work item, and the selection of Oracle 
Workflow process to execute for a given work item.

Service to Work Item Dynamic Mapping
During order capturing time, SFM will need to determine which work items to 
execute for a given service. Sometimes the list of work items to execute for a service 
is fixed and can be defined by an SFM user during configuration time through the 
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SFM Configurator. Sometimes the list of work items to run can vary depends on 
certain parameter values in the order during runtime. For example, a company can 
have a Nortel network and a Lucent network on different geographical areas and 
the work items for the same service can vary depends on which network it will be 
provisioned on. SFM provides a solution to such problem by allowing the user to 
define business logic in the service to work item mapping procedure, where the 
user can instruct SFM to execute different set of work items base on the actual value 
of a service parameter, the area code for example. An example will be given later in 
this chapter.

Procedure Specification
When defining the service to work item mapping procedure through the 
Configurator, SFM will automatically generate the following procedure 
specification:

procedure <name of the procedure>(
         p_order_id IN NUMBER,
         p_line_item_id IN NUMBER,
         p_return_code OUT NUMBER,
         p_error_description OUT VARCHAR2)

The user can not change the procedure specification. However, the user can refer to 
those procedure parameters as desire anywhere in the procedure body. 

 

Item to Fulfillment Action Dynamic Mapping

During work item execution, SFM will need to determine which Service Fulfillment 
Manager activities, namely fulfillment actions, need to be executed for a given 
Service Fulfillment Manager job, namely work item. Sometimes the list of 
fulfillment actions (FAs) to execute for a work item is fixed and can be defined by 
an SFM user during configuration time through the SFM Configurator. Sometimes 
the list of FAs to run can vary depends on certain parameter value in the order 
during runtime. For example, a work item PROVISION_CARRIER_SWITCH may 
invoke different FAs depends on the long distance carrier the customer chooses. 
SFM provides a solution to such problem by allowing the user to define business 
logic in the work item to FA mapping procedure, where the user can instruct SFM to 
execute different set of FAs base on the actual value of a service parameter, the 
carrier code for example. An example will be given later in this chapter.
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Predefined Fulfillment Element Types in Oracle Number Portability
The Oracle Number Portability application is preseeded with a number of 
fulfillment element types. The following table lists these predefined element types.

Table 1-12  Element Types in Oracle Number Portability

Procedure Specification
When defining the work item to FA mapping procedure through the Configurator, 
SFM will automatically generate the following procedure specification:

procedure <name of the procedure>(
         p_order_id IN NUMBER,
         p_line_item_id  IN NUMBER,
         p_wi_instance_id IN NUMBER,
         p_return_code OUT NUMBER,
         p_error_description OUT VARCHAR2)

The user can not change the procedure specification. However, the user can refer to 
those procedure parameters as desire anywhere in the procedure body. 

1.1.27 Work Item Workflow Execution Procedure
Sometimes the work item execution can be a really complex process. For example, 
when a customer orders a T1 circuit, the carrier may need to get a circuit design 
first, and then provision the appropriate fulfillment elements accordingly. In such 
case SFM will not be able to determine which FA to execute for this particular work 
item at the beginning of the Service Fulfillment Manager process due to the fact 

Element Type Description

DIRECTORY_
GATEWAY

Refers to directory assistance gateway

NRC_GATEWAY Refers to the Number Registration Center gateway

SCP Refers to the LNP database for all service control points

SP_GATEWAY Refers to messaging gateways for remote systems of other 
service providers

SSP Refers to signal switching point

STP Refers to signal transfer point
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that, the next FA execution is solely base on the execution result of the previous FA. 
SFM addresses this problem by allowing the user to associate an Oracle Workflow 
with the work item, where the users can define their own business process flow for 
the work item execution. In some practice the user may want to define multiple 
workflow processes for the same work item base on their network implementation. 
For example, they may have different network configuration on different 
geographical areas which in turn may require different business process to execute 
for the same work item. The user can then implement their workflow selection rules 
in the work item workflow execution procedure, which SFM will use to select the 
appropriate workflow process base on the order information at runtime.

Procedure Specification
When defining the work item workflow execution procedure through the 
Configurator, SFM will automatically generate the following procedure 
specification:

procedure <name of the procedure>(
      p_order_id IN NUMBER,
      p_line_item_id  IN NUMBER,
      p_wi_instance_id IN NUMBER,
      p_wf_item_type OUT varchar2,
      p_wf_item_key  OUT varchar2,
      p_wf_process_name  OUT varchar2,
      p_reurn_code OUT NUMBER,
      p_error_description OUT VARCHAR2)

The user can not change the procedure specification. However, the user can refer to 
those procedure parameters as desire anywhere in the procedure body. 

1.1.28 Service Fulfillment Manager Activities Execution
The user should be able to define business rules in the following PL/SQL 
procedures for evaluating the parameter value at runtime, identifying which 
fulfillment element to run against for an FA, and Service Fulfillment Manager a 
fulfillment element for an FA.

Work Item Parameter Evaluation Procedure
This procedure allows the user to evaluate a work item parameter value at runtime. 
For example, the user can use this procedure to retrieve value for certain Service 
Fulfillment Manager specific parameter from systems such as network inventory 
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database, or change the format of the work item parameter value to best fit their 
business need. 

Procedure Specification

When defining work item parameter evaluation procedure through the 
Configurator, SFM will automatically generate the following procedure 
specification:

procedure <name of the procedure>(
     p_order_id IN NUMBER,
     p_line_item_id    IN NUMBER,
     p_wi_instance_id IN NUMBER,
     p_param_valIN Varchar2,
     p_param_ref_valIN Varchar2,
     p_param_eval_val  OUT VARCHAR2,
     p_param_eval_ref_val  OUT Varchar2,
     p_return_codeOUT NUMBER,
     p_error_description  OUT VARCHAR2)

The user can not change the procedure specification. However, the user can refer to 
those procedure parameters as desire anywhere in the procedure body. 

1.1.29 Fulfillment Action Parameter Evaluation Procedure
This procedure allows the user to evaluate a fulfillment action parameter value at 
runtime. For example, the user can use this procedure to retrieve value for certain 
Service Fulfillment Manager specific parameter from systems such as network 
inventory database, or change the format of the work item parameter value to best 
fit their business need. 

Procedure Specification

When defining work item parameter evaluation procedure through the 
Configurator, SFM will automatically generate the following procedure 
specification:

procedure <name of the procedure>(
      p_order_id IN NUMBER,
      p_line_item_id IN NUMBER,
      p_wi_instance_id IN NUMBER,
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      p_fa_instance_id IN NUMBER,
      p_param_valIN Varchar2,
      p_param_ref_valIN Varchar2,
      p_param_eval_val  OUT VARCHAR2,
      p_param_eval_ref_val  OUT Varchar2,
      p_return_codeOUT NUMBER,
      p_error_description  OUT VARCHAR2)
The user can not change the procedure specification. However, the user can refer to 
those procedure parameters as desire anywhere in the procedure body. 

1.1.30 Fulfillment Element Routing Procedure
This procedure allows the user to identify which fulfillment element to provision 
for a fulfillment action based on the order information at runtime. 

Procedure Specification
When defining fulfillment element routing procedure through the Configurator, 
SFM will automatically generate the following procedure specification:

procedure <name of the procedure>(
      p_order_id IN NUMBER,
      p_line_item_id      IN NUMBER,
      p_wi_instance_id IN NUMBER,
      p_fa_instance_id IN NUMBER,
      p_fe_name  OUT Varchar2,
      p_return_codeOUT NUMBER,
      p_error_description  OUT VARCHAR2)

The user can not change the procedure specification. However, the user can refer to 
those procedure parameters as desire anywhere in the procedure body. 

1.1.31 Fulfillment Procedure
This procedure allows the user to define the Service Fulfillment Manager logic on a 
particular fulfillment element type for a fulfillment action. The user will be able to 
use a set of macros provided by SFM to send the appropriate commands or message 
to the fulfillment element, examine the response from the fulfillment element and 
determine the next command or message accordingly. 
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Procedure Specification
When defining work item parameter evaluation procedure through the 
Configurator, SFM will automatically generate the following procedure 
specification:

procedure <name of the procedure>(
      p_order_id IN NUMBER,
      p_line_item_id      IN NUMBER,
      p_wi_instance_id IN NUMBER,
      p_fa_instance_id IN NUMBER,
      p_channel_nameIN Varchar2,
      p_fe_nameIN VARCHAR2,
      p_fa_item_type   IN VARCHAR2,
      p_fa_item_key    IN VARCHAR2,     
      sdp_internal_err_codeOUT NUMBER,
      sdp_internal_err_str OUT VARCHAR2)

The user can not change the procedure specification. However, the user can refer to 
those procedure parameters as desire anywhere in the procedure body. 

1.1.32 Network Communication Process
Sometimes the communication between SFM and the fulfillment element may 
require SFM to open a connection to the equipment before passing messages or 
commands to the FE. This chapter will describe how to implement the connection 
logic in the connect/disconnect procedure which will be executed by SFM when a 
communication channel is established between SFM and the fulfillment element.

1.1.33 Connect Procedure
This procedure allows the user to instruct SFM how to establish a connection to a 
fulfillment element.

Procedure Specification
When defining connect procedure through the Configurator, SFM will 
automatically generate the following procedure specification:

procedure <name of the procedure>(
     p_fe_name IN Varchar2,
     p_channel_nameIN Varchar2,
     p_return_code IN OUT NUMBER,
     p_error_description IN OUT VARCHAR2
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)
The user can not change the procedure specification. However, the user can refer to 
those procedure parameters as desire anywhere in the procedure body. 

1.1.34 Disconnect Procedure
This procedure allows the user to instruct SFM how to close a connection from a 
fulfillment element.

Procedure Specification
When defining connect procedure through the Configurator, SFM will 
automatically generate the following procedure specification:

procedure <name of the procedure>(
     p_fe_name IN Varchar2,
     p_channel_nameIN Varchar2,
     p_return_code IN OUT NUMBER,
     p_error_description IN OUT VARCHAR2)

The user can not change the procedure specification. However, the user can refer to 
those procedure parameters as desire anywhere in the procedure body. 

1.1.35 Managing Network Connections
You use the Connection Manager to manage all types of fulfillment elements and 
their Adapters. The Connection Manager is used to control network connections.

You perform the following tasks using the Connection Manager:

■ Monitoring network connections

■ Defining a new adapter

■ Redefining an adapter

■ Scheduling an adapter

■ Deleting an adapter

■ Viewing adapter request errors

■ Issuing a disconnect request

■ Issuing a connect request

■ Issuing a suspend request
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■ Issuing a resume operation request

Monitoring Network Connections
To view the network associated with a fulfillment element, perform the following 
steps.

Prerequisites
None

Steps
1. In the Navigator, choose Administration > Connection Manager.

The Connection Manager opens.

2. Click Enter a filtering value if you wish to filter the list of fulfillment elements 
that display in the left-hand frame. 

Conversely, erase the filtered value entry to view all defined fulfillment 
elements.

3. Select a fulfillment element from the list.

4. Select the Adapters tab to view information about Adapters.

5. Select the adapter type to view from the Usage drop-down list. Your choices are:

■ All Types

■ Messaging

■ Order resubmission

■ Service Fulfillment Manager

■ Testing

6. Choose one of the following:

■ Chose the Adapters sub-tab to view information about the current status of 
an adapter.

■ Chose the Options sub-tab to display the adapter display name and 
arguments for the adapter.

■ Chose the Modes sub-tab to view information about Startup and Debug 
modes for an adapter.
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■ Chose the Requests sub-tab to view to view information about how the 
adapter has been scheduled.

7. Click the "x" in the right-hand corner of the form window to close the form 
window.

Defining a New Adapter Instance
To define a new adapter in the system, perform the following steps.

Prerequisites
None

Steps
1. In the Navigator, choose Administration > Connection Manager.

2. Select the Adapters tab.

3. Click New... to open the Adapter Properties dialog box.

4. Enter a name for the new adapter.

5. Select a value from the Usage drop-down list. 

6. Select a value from the Startup Mode drop-down list.

7. Select a value from the Debug Mode drop-down list of values.

8. Click OK to define the new adapter and close the dialog box.

The new adapter now displays in the list of adapters.

Redefining an Adapter
To edit an adapter definition, perform the following steps.

Prerequisites
The Current Status field for the adapter must display Shutdown for this option to 
be available.

WARNING: You can start a new adapter only if it does not 
exceed the maximum number of connections allowed (or 
configured) for that specific fulfillment element.
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Steps
1. In the Navigator, choose Administration > Connection Manager.

2. Select the adapter from the list at the left.

3. Select the Adapters tab.

4. Click Edit. 

5. The Adapter Properties dialog box displays.

6. Make changes as necessary.

7. Click OK to redefine the adapter and close the dialog box.

Scheduling an Adapter
To schedule a request for an adapter, perform the following steps.

Prerequisites
You can not schedule a request prior to the current date and time.

Steps
1. In the Navigator, choose Administration > Connection Manager.

2. Select the Adapters tab.

3. Click Schedule... to open the Adapter Request dialog box.

4. Chose a value from the Request Type drop-down list of values.

5. Chose a date and time for the request to execute the request. (If desired, open 
the Calendar function by clicking the [...] at the edge of the Date/Time field.)

■ To issue the request immediately, enter the current date and time.

■ To postpone the execution of the request, enter a future date.

6. Enter the period (in days) that the adapter request is to repeat by entering a 
value in the Repeat Every (days) field. 

■ To schedule a request only once, leave this field blank.

7. Click OK to schedule the request and close the dialog box.

Note: To delete a scheduled request, select it and click Delete.
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Deleting an Adapter
To delete an adapter from the system, perform the following steps.

Prerequisites
The Current Status field for the adapter must display Shutdown for this option to 
be available.

Steps
1. In the Navigator, choose Administration > Connection Manager.

2. Select the adapter to delete from the list of adapters.

3. Click Delete. 

The adapter no longer displays in the list of adapters.

Viewing Adapter Request Errors
If an adapter request causes an error condition, the Current Status field for that 
adapter displays Error. 

To view details of the error condition, perform the following steps.

Prerequisites
The Current Status field for that adapter must display Error for this option to be 
available.

Steps
1. In the Navigator, choose Administration > Connection Manager.

2. Select the adapter from the list of adapters at the left.

3. Select the Adapters tab.

4. Click Show Error. 

The time the error message occurred and the text of the error message display.

5. Click OK to close the Error Message window.

Issuing a Disconnect Request
To issue a disconnect request to an adapter, perform the following steps.
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Prerequisites
The Current Status field for that adapter must display Running for this option to be 
available.

Steps
1. In the Navigator, choose Administration > Connection Manager.

1. Select the adapter from the list of adapters at the left.

2. Select the Adapters tab.

3. Click Disconnect. 

The Current Status field for this adapter now displays Disconnected.

Issuing a Connect Request
To issue a connect request to an adapter, perform the following steps.

Prerequisites
The Current Status field for the adapter must display Disconnected for this option 
to be available.

Steps
1. In the Navigator, choose Administration > Connection Manager.

2. Select the adapter from the list of adapters at the left.

3. Select the Adapters tab.

4. Click Connect.

The Current Status field for this adapter now displays Running.
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Issuing a Suspend Request
To issue a suspend request to an adapter, perform the following steps.

Prerequisites
The Current Status field must display Running for this option to be available.

Steps
1. In the Navigator, choose Administration > Connection Manager.

2. Select the adapter from the list of adapters at the left.

3. Select the Adapters tab.

4. Click Suspend.

The Current Status field for this adapter now displays Suspended.

Issuing a Resume Operation Request
To issue a resume request to an adapter, perform the following steps.

Prerequisites
The Current Status field must display Suspended for this option to be available.

Steps
1. In the Navigator, choose Administration > Connection Manager.

2. Select the adapter from the list of adapters at the left.

3. Select the Adapters tab.

4. Click Resume.

The Current Status field for this adapter now displays Running.

1.1.36 Managing Services
You perform a number of tasks with services. These include:

■ Defining a new service

■ Associating actions with services

■ Associating work items with service actions

■ Editing an existing action
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■ Deleting a service

For the steps and tasks associated with setting up a service, see Configuring 
Services for an overview of the processes involved.

Configuring Services
The tasks necessary to configure a service are described in the following steps.

Prerequisites
None

Steps
In configuring services, you must define all of the following items.

Defining a New Service
Services are also referred to as products or service offerings. In each case, however, 
they represent services deployed by a service provider who delivers, activates, 
maintains and bills a subscriber for it.

To define a new service, perform the following steps.

Item See

1. The details of the service (for example, 
version, description and activation dates)

Defining a New Service

2. The actions available for a specific service and 
version

Associating Actions with a Service

3. The work items used by the service actions Associating Work Items with Service 
Actions
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Prerequisites
None

Steps
1. In the Navigator, choose Setup > Service Definitions > Services.

2. Select the Details tab.

3. Click the New icon on the task bar.

This action causes a blank entry to display in the Services list at the left.

4. Enter a value for the Display Name. 

This is the name of the service that is to display in the audit trail and during 
configuration.

5. Enter a value for the Internal Name. 

This is the name for the service that is to be used internally by the system 
during Service Fulfillment Manager.

6. Enter a version number.

7. Check the Provision this Service box.

■ If you check this box, then you can submit an order against the service.

■ If you do not check this box, then the configuration of this service is still in 
progress, and an order can not be submitted against the service.

8. Enter a short description in the Description field. 

9. Enter the effective date for this service to become active. 

10. Enter the effective date for this service to become inactive.

11. Enter a value for Responsibility.

This sets who is responsible to maintain this information. 

12. Close the window.

13. Save your changes.

To complete the definition, you need to associate an action with this service.
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Associating Actions with a Service
An action is an operation performed on a service, product, and package. It instructs 
the Service Delivery Platform to internally call pre-defined sets of activities, rules, 
or data. 

For every service that you define, you need to assign an action for Service 
Fulfillment Manager that desired service. A service combined with an action creates 
the definition of an order line item.

You can repeat an action across various services, however, this action may not 
necessarily be valid across all fulfillment elements. 

To create a new service action, perform the following steps.

Prerequisites
You must define a service before associating actions with it. (You may also reuse an 
existing service.) See Defining a New Service for details.

Steps
1. In the Navigator, choose Setup > Service Definitions > Services.

2. Select the Actions tab.

3. Select an action from the Available Actions list.

■ If you do not see the name of the desired action in the Available box, enter 
the name of the action in the Filter field and click the Find icon to search for 
it.

■ If the action is not defined yet, click Define Actions to open the Define 
Actions window and then add it.

4. Use the arrow buttons to move your choice from the Available Actions list to 
the Selected Actions list.

5. Enter a value for the Start Date. 

This is the date at which this action becomes available to the service.

6. Enter a value for the End Date. 

This is the date at which this action becomes unavailable.

Note: It is possible to associate multiple actions with a single 
service.
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7. Enter a Description for this action.

8. Enter a name for the Work Item Mapping Procedure. 

If necessary, click the Add/Edit Procedure icon to launch the procedure builder 
and define a new procedure. See Using the Procedure Builder for details of this 
process.

9. Close the window.

10. Save your changes.

Associating Work Items with Service Actions
To associate a work item with a service action, perform the following steps.

Prerequisites
Each service action can have one or more work items defined for it. However, there 
must be at least one work item for any available service action.

Steps
1. In the Navigator, choose Setup > Service Definitions > Services.

2. Select a service from the list at the left.

3. Select the Work Items for Action tab.

4. Select an action from the drop down list of available actions associated with this 
service.

If you do not see the action that you desire, you need to select the Actions tab 
and add the desired action to the list of Selected Actions. 

5. Select a work item from the Available Work Items list.

■ If you do not see the name of the desired work item in the Available box, 
enter the name of the work item in the Filter field and click the Find icon to 
search for it.

■ If the work item is not defined, click Define Work Items to open the Define 
Work Items window and then add it. See Defining a New Work Item for 
details, if necessary.

6. Use the arrow buttons to move your choice from the Available Work Items list 
to the Selected Work Items list.

7. Enter a descriptive comment in the Details of a Selected Work Item field, if 
desired.
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8. Repeat steps 4 through 8 as many times as necessary.

9. Close the window. 

10. Save and exit.

Editing an Existing Action
To edit an existing service action, perform the following steps.

Prerequisites
None

Steps
1. In the Navigator, choose Setup > Service Definitions > Services.

2. Select the Action tab.

3. Click Define Actions.

4. Select an existing action from list.

5. Modify the action parameters as desired.

6. Close the window. 

7. Save your changes.
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Deleting a Service
To delete a service, perform the following steps.

Prerequisites
You can not delete a service if either the following conditions is true:

■ If the allowable actions on the service have previously been defined.

■ If orders have been running for that service.

Steps
1. In the Navigator, choose Setup > Service Definitions > Services.

2. Select a service from the list at the left.

3. Click Delete.

The service disappears from the list.

4. Close the window. 

5. Save your changes.

1.1.37 Packages
You perform several different tasks with service packages. These include:

■ Defining a new service package

■ Associating services with packages

Defining a New Service Package
To create a new package of services, perform the following steps.

Prerequisites
None
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Steps
1. In the Navigator, choose Setup > Service Definitions > Packages.

2. Select the Details tab.

3. Enter a value for the Display name. 

This is the name of the package that is to display in the audit trail and during 
configuration.

4. Enter a value for the Internal name. 

The system stores this name in its database to identify the package. (Use 
underscores rather than blanks in the package name.)

5. Enter a value for the Description.

6. Enter a value for the Start Date. 

This is the date at which this package becomes available.

7. Enter a value for the End Date. 

This is the date at which this package becomes unavailable.

8. Close the window. 

9. Save your changes.

Associating Services with Packages
To associate a service with a package, perform the following steps.

Prerequisites
You must define the service package before you add services to it. See Defining a 
New Service Package for details.
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Steps
1. In the Navigator, choose Setup > Service Definitions > Services.

2. Select the Services tab.

3. Select a service from the Available Services list.

■ If you do not see the name of the desired service in the Available box, enter 
its name in the Filter field and click the Find icon to search for it.

■ If the service is not defined yet, click Define Services and then add it. See 
Defining a New Service for details.

4. Use the arrow buttons to move your choice from the Available list to the 
Selected list.

5. Enter an Activation Sequence value for each service listed under Selected 
Services. 

This value determines the order in which the listed services are activated.

6. Check Service Fulfillment Manager Required if this service is to be provisioned 
by the Service Delivery Platform.

■ If you check this box, then the service is provisioned through the Service 
Delivery Platform

■ If you do not check this box, then the service is defined within the Service 
Delivery Platform Configurator, but is not necessarily activated through the 
Service Delivery Platform. 

This feature enables Service Providers to implement the identical service name 
among different Service Fulfillment Manager medium without conflict.

7. Enter a comment in the Comment field, if desired. 

8. Close the window. 

9. Save your changes.

1.1.38 Work Items
You perform a number of tasks with work items. These include:

■ Defining a new work item

■ Deleting a work item

■ Defining a new work item parameter
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■ Adding parameters to a work item

■ Associating fulfillment actions with work items

Defining a New Work Item
To define a new work item, perform the following steps.

Prerequisites
If you plan to associate a workflow with this work item, then you must create the 
workflow before you create the work item.

Steps
1. In the Navigator, choose Setup > Service Definitions > Work Items.

2. Click the New icon on the toolbar. 

This action causes a blank Details window to display.

3. Enter the Display name. 

System screens display this name for the work item.

4. Enter an Internal name. 

The system stores this name for the work item in its database. 

5. Enter the Version. 

The Service Delivery Platform allows multiple versions of a work item.

6. Enter the Duration. 

The work item stays active for this length of time.

7. Enter a Description for this work item.

8. Enter the Begin Date. 

The work item becomes available on this date.
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9. Enter the End Date. 

The work item is no longer available after this date.

10. Chose a Work Item Type from the drop down list. 

See Guidelines following for details of work item types.

11. Chose a user role from the drop down list for Responsibility.

This determines who is responsible to maintain this information (a user, a 
group, or a user group). It can also be used for fault resolution assignment (i.e., 
assigning it to the person responsible for ensuring that the problem is resolved).

12. Close the window. 

You are prompted to save your changes.

Guidelines
Use the following information in determining the type of work item to choose.

Table 1-13 Work Item Types

WI Type Comments

Static If selected, then you must also define the fulfillment 
actions associated with this work item. 

See Associating Fulfillment Actions with Work 
Items for details.

Dynamic If selected, then you must also select a procedure 
from a list of existing procedures or create a new 
procedure. The procedure determines the list of 
fulfillment action’s and their sequence at runtime. 

User-defined workflow If selected, enter the Item Type, Process and Key 
Prefix. 

You must also enter the name of the workflow that 
you have created. (Remember that any workflow 
that you create must be saved to the general Service 
Delivery Platform engine before it is accessible for 
use.)

User workflow start 
procedure

If selected, then you must enter the name of the 
workflow procedure also, or define a new one.
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Deleting a Work Item
To delete an existing work item, perform the following steps.

Prerequisites

The data must be visible in your log in role for you to delete it.

Steps
1. In the Navigator, choose Setup > Service Definitions > Work Items.

2. Select a work item from the list at left.

3. Click Delete. 

The system performs a validation procedure to determine that there are no ill 
effects to deleting this work item. For example, it checks to see that no 
parameters or fulfillment actions are assigned to the work item to be deleted. If 
if passes the validation procedure, then the work item is deleted by the system 
and it is removed from the list.

Defining a New Work Item Parameter
To define a new work item, perform the following steps.

Prerequisites
None

Steps
1. In the Navigator, choose Setup > Service Definitions > Work Items.

2. Select the Parameters tab.

3. Click Define Parameters.

The Define Parameters window opens.

4. Click the New icon on the toolbar.

A blank entry opens in the Display Name list at the left.

5. Enter a value for the Internal Name of the parameter.

The Service Delivery Platform stores this name in its database fro internal use 
by the system.

6. Enter a description for the new parameter.

7. Close the window.
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8. Save your work.

Adding Parameters to a Work Item

To add parameters to a work item, perform the following steps.

Prerequisites
None

Steps
1. In the Navigator, choose Setup > Service Definitions > Work Items.

2. Select the Parameters tab.

3. Select a parameter from the Available Parameters list.

If you do not see the name of the desired parameter in the Available box, enter 
its name in the Filter field and click the Find icon to search for it.

4. Use the arrow buttons to move your choice from the Available list to the 
Selected list.

5. (Optional) Enter a Display Sequence number for each item in the Selected 
Parameter list. 

This value determines the order in which the parameter displays in the work 
item sequence.

6. (Optional) Enter a Evaluation Sequence number for each item in the Selected 
Parameter list. 

This value determines the order in which the work item evaluates the 
parameter.

7. Check the Required box if this parameter must be present in order to provision 
the service.

8. Check the Log in Audit Trail box if this parameter is to be logged and visible in 
the audit trail.

Parameters that have this box checked (and are actually used with an order), 
become visible in the audit trail.

9. Enter a Default Value, if desired. 
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This value is displayed in the order, and is changed by the user. For example, 
this could be an IP address or a password.

10. Enter a value in the Value Lookup SQL field. 

This value is an SQL statement that evaluates the parameter value. If necessary, 
click Edit Lookup SQL to launch the SQL editor.

11. Enter a mode for when evaluation of this parameter occurs, if desired. 

The available choices are:

■ Upon order receipt

■ Upon Retrieval

■ Upon Work Item Start

See the Work Item Mode Guidelines following for considerations on choosing a 
work item mode.

12. (Mandatory, if a mode is selected in step 11, otherwise, ignore.) Enter a name for 
the procedure to be used in evaluating the parameter value. 

If necessary, click the Add/Edit procedure icon to launch the procedure builder 
and define a new procedure. See Using the Procedure Builder for details of this 
process.

13. Close the window.

14. Save your work.

Work Item Mode Guidelines
You may wish to review the following information before selecting a work item 
mode.

Order Receipt
If you select Upon Order Receipt, then you must also define a name for the 
procedure and write the body for the evaluation procedure.

The following steps are performed by the Service Fulfillment Manager if a 
parameter is marked as Upon Order Receipt. The Service Fulfillment Manager:

■ Receives an order from the upstream system with the parameter and its value.

■ Performs validation on the parameters.

■ Executes the evaluation procedure.
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■ Stores the value of the parameter returned from the evaluation procedure. (This 
value is used in further processing.)

Upon Retrieval

If you select Upon Service Fulfillment Manager Order, then you must also define a 
name for the procedure and write the body for this procedure. 

The following steps are performed by the Service Delivery Platform if a parameter 
is marked as When Service Fulfillment Manager Order. The Service Delivery 
Platform:

■ Receives an order from an upstream system with the parameter and its value.

■ Performs validation on the parameters.

■ Stores the value of the parameter as is, without any further manipulation.

■ At runtime, whenever the parameter is referenced, the associated When Service 
Fulfillment Manager Order procedure is executed to obtain the new value.

■ The new value is used for order processing.

Associating Fulfillment Actions with Work Items
To associate a fulfillment action with a work item, perform the following steps.

Prerequisites
You can only associate fulfillment actions with either static or dynamic work items.

Steps
1. In the Navigator, choose Setup > Service Definitions > Work Items.

2. Select a work item from the list at left.

3. Select the Fulfillment Actions tab.

The work item type must be static for the Fulfillment Actions tab to be 
accessible.

4. Select a fulfillment action from the Available Fulfillment Actions list.

■ If you do not see the name of the desired fulfillment action in the Available 
box, enter the name of the fulfillment action in the Filter field and click the 
Find icon to search for it.
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■ If the user account is not defined yet, click Define Fulfillment Actions to 
open the Define Fulfillment Actions window and then add it. See 
Configuring Fulfillment Actions for details on adding a new fulfillment 
action.

5. Use the arrow buttons to move your choice from the Available Fulfillment 
Actions list to the Selected Fulfillment Actions list.

6. Enter a Service Fulfillment Manager Sequence number for each item in the 
Selected Fulfillment Actions list. 

7. Enter a Comment for this fulfillment action, if desired.

8. Close the window.

9. Save your changes.

1.1.39 Managing Fulfillment Actions
You perform a number of tasks with fulfillment actions. These include:

■ Configuring fulfillment actions

■ Adding parameters to a fulfillment action

■ Associating a fulfillment procedure with a fulfillment action

■ Modifying a fulfillment action procedure

Configuring Fulfillment Actions
To define a new fulfillment action, perform the following steps.

Prerequisites
You must perform the following tasks before configuring fulfillment actions:

■ Configure parameters: See  Adding Parameters to a Work Item.

Note:  User can define the FA Parameters right in the Parameters tab of the FA. 
User may enter any parameter name and a display value.

■ Configure fulfillment element types: See Defining a Fulfillment Element Type.

■ Configure fulfillment elements: See Defining a New Fulfillment Element.

■ Build the fulfillment procedures: See Using the Procedure Builder.
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Steps
1. In the Navigator, choose Setup > Service Definitions > Fulfillment Actions.

The Fulfillment Actions window opens.

2. Click the New icon on the toolbar, or chose File > New from the menu.

A new, blank entry opens in the Fulfillment Actions list at the left.

3. Enter a value for the Display name. 

This is the name of the fulfillment action that is to display in the audit trail and 
during configuration.

4. Enter a value for the Internal name. 

This is the name for the fulfillment action that is to be used internally by the 
system during Service Fulfillment Manager.

5. Enter the Version number for this fulfillment action.

6. Enter a value for the fulfillment procedure to select the PL/SQL procedure to 
execute.

7. Chose one of the available Fulfillment Element Routing procedures from the 
drop down list. 

If necessary, click the icon next to the Procedure field and create a routing 
procedure for use here. See Using the Procedure Builder for details.

8. Enter a value for Evaluate a Parameter. 

If necessary, click the icon next to the Procedure field and create an evaluation 
procedure for use here. See Using the Procedure Builder for details. 

9. Chose a Responsibility from the drop down list, if desired. 

If this field is left blank, any user role can use this fulfillment action.

10. Save your work.

Adding Parameters to a Fulfillment Action
To associate parameters with a fulfillment action, perform the following steps.
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Prerequisites
None

Steps
1. In the Navigator, choose Setup > Service Definitions > Fulfillment Actions.

2. Select a fulfillment action from the list at the left.

3. Select the Parameters tab.

4. Select a parameter from the Available Parameters list.

■ If you do not see the name of the desired parameter in the Available box, 
enter its name in the Filter field and click the Find icon to search for it.

■ If the parameter is not defined yet, click Define Parameters and then add it. 
See Defining a New Work Item Parameter for details.

5. Use the arrow buttons to move your choice from the Available list to the 
Selected list.

6. (Optional) Enter a Display Sequence number for each item in the Selected 
Parameter list. 

This value determines the order in which the parameter displays in the 
fulfillment action sequence.

7. Check the Log in Audit Trail box if this parameter is to be logged and visible in 
the audit trail.

8. Enter a Default Value, if desired. 

This value is displayed in the order, and is changed by the user. For example, 
this could be an IP address or a password.

9. Enter a name for the Evaluation Procedure to be used in evaluating the 
parameter value. Specify an evaluation procedure for each parameter that you 
need to define, if desired.

If necessary, click the icon next to the Procedure field to launch the procedure 
builder and define a new procedure. See Using the Procedure Builder for 
details of this process.

Note: A fulfillment action can have more than one parameter 
associated with it.
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10. Click the Save icon on the toolbar to save your changes.

11. Select File > Close to exit.

Associating a Fulfillment Procedure with a Fulfillment Action
To associate fulfillment procedures with a fulfillment action, perform the following 
steps. 

Prerequisites
A single fulfillment action can have more than one fulfillment procedures defined. 
However, it must have at least one procedure to indicate the adapter type. 

Steps
1. In the Navigator, choose Setup > Service Definitions > Fulfillment Actions.

2. Select a fulfillment action from the list at left.

3. Select the Fulfillment Procedures tab.

4. Chose a Fulfillment Element Type from the drop down list.

If necessary, click Define Types and create a new fulfillment element type.

5. Enter a value for Software Version (Adapter Type) to set the software version 
and the connect/disconnect values.

6. Enter a value for the fulfillment procedure to select the PL/SQL procedure to 
execute.

If necessary, click the icon next to the Procedure field and create a new 
procedure for use here.

7. Click the Save icon on the toolbar to save your changes.

8. Select File > Close to exit.
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Modifying a Fulfillment Action Procedure
To modify or edit an existing fulfillment procedure, perform the following steps.

Prerequisites
None

Steps
1. In the Navigator, choose Setup > Service Definitions > Fulfillment Actions.

1. Click the icon next to the Procedure field that you wish to modify.

The Add/Edit Procedure window opens.

2. Modify the procedure as desired.

3. Click the Save icon on the toolbar to save your changes.

4. Select File > Close to exit.

1.1.40  Procedure Builder
You use the procedure builder to perform the following tasks:

■ Creating a new procedure

■ Deleting an existing procedure

■ Viewing procedure parameters

■ Editing an existing procedure

Creating a New Procedure
To create a new procedure, perform the following steps.

Prerequisites
None
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Steps
1. Open the Add/Edit Procedure window by clicking the icon next to the 

Procedure field.

2. Verify the procedure Type. 

This field is read-only. Its value depends on the form field that called the 
Add/Edit Procedure window.

3. Enter the internal name for this procedure. 

The Service Delivery Platform uses this name to reference the procedure in its 
database.

4. Enter the display name. 

This name is displayed in the system screens.

5. Enter a description of this procedure.

6. Do one of the following:

■ Enter the desired PL/SQL code in the Procedure code field.

■ Click Copy From to copy the code from an existing procedure. Use the Edit 
function to modify it to meet your needs.

See Guidelines following for details on guidelines to use during the creation of 
a procedure.

7. Click OK to compile and generate the procedure.

Guidelines
Use the following guidelines during creation of a procedure.

■ Do not use an initial DECLARE statement at the beginning of the code block

■ Use the provided Script Notepad to write your Service Fulfillment Manager 
procedure.

■ The following is an example of a connection procedure.):

  err_code number;
  err_str     varchar2(400);
BEGIN
  LOGIN(‘telnet $ip_address $portnumber’, ‘$username_prompt’, err_code, err_str);
     SEND('$username', '$password_prompt', err_code, err_str);
     SEND('$password', '$login_prompt', err_code, err_str);
EXCEPTION
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WHEN OTHERS THEN
   RAISE;
END;

■ Always add the EXCEPTION block at the end of your procedure:

EXCEPTION
WHEN OTHERS THEN
   RAISE
END;

■ You must compile and generate the procedure after finishing the code by 
clicking OK.

The procedure builder prompts you with compilation errors if you have either 
of the following conditions exist:

■ The procedure contains unrecognized parameters.
I

Deleting an Existing Procedure
To delete an existing procedure, perform the following steps.

Prerequisites
The procedure to be deleted must not be used by any other objects.

Note: To display a list of the parameters that can be used in the 
Service Fulfillment Manager procedure, click Available 
Parameters.

The displayed parameters are the internal names of the service 
parameters that you previously configured. Only these internal 
names can be used inside the Service Fulfillment Manager 
procedure body.
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Steps
1. Open the Add/Edit Procedure window by clicking the icon next to the 

Procedure field.

2. Verify that the procedure Type lists the procedure that you wish to delete.

3. Click the Delete icon on the toolbar.

4. Click the Save icon on the toolbar to save your changes.

5. Select File > Close to exit.

Viewing Procedure Parameters
To view the parameters or attributes which can be used in the procedure, perform 
the following steps.

Prerequisites
None

Steps
1. Open the Add/Edit Procedure window by clicking the icon next to the 

Procedure field.

2. Click Attributes.

3. Click OK to close the Parameters window. 

4. Click OK to exit the Add/Edit Procedure window.

Note: The parameters or attributes displayed are the internal 
names of the fulfillment element attributes that you have 
previously configured. Only internal names can be used inside the 
procedure body.
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Editing an Existing Procedure
To edit an existing procedure, perform the following steps.

Prerequisites
Do not modify a default procedure.

Steps
1. Open the Add/Edit Procedure window by clicking the icon next to the 

Procedure field.

2. Verify the procedure type. 

This field is read-only. Its value depends on the form field that called the 
Add/Edit Procedure window.

3. Click on the Procedure Code field.

4. Select Edit > Edit Field from the menu.

5. Modify the PL/SQL code in the Procedure Code text field.

6. Click OK to compile and generate the procedure.

1.1.41 Managing Fulfillment Element Types
For every fulfillment element that you define, there must first exist a definition of 
that fulfillment element type.

The following tasks are associated with fulfillment elements types:

■ Defining a fulfillment element type

■ Deleting a fulfillment element type

Defining a Fulfillment Element Type

To define a new fulfillment element type, perform the following steps.

Note: Any service order request provisioned through the Service 
Delivery Platform requires that a specific fulfillment order type for 
that request also be configured through the Service Delivery 
Platform.
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Prerequisites
Fulfillment element types are defined by system experts only.

Steps

1. In the Navigator, choose Setup > Interface Definition > Fulfillment Element 
Types.

The Fulfillment Element Types window opens.

2. Select the Details tab.

3. Click Define Types.

4. Click Add. 

This action causes a blank Define Fulfillment Element Types window to open.

5. Complete the fields in the Details tab.

6. Complete the fields in the Attributes tab.

7. Complete the fields in the Software tab.

8. Close the window. 

9. Save your changes.

Deleting a Fulfillment Element Type
To delete an existing fulfillment element type, perform the following steps.

Prerequisites
You can not delete a fulfillment element type if either one of the following 
conditions is true:

■ The attributes for this fulfillment element have previously been defined 

■ The software versions for this fulfillment element previously have been defined
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Steps
1. In the Navigator, choose Setup > Interface Definition > Fulfillment Element 

Types.

The Fulfillment Element Types window opens.

2. Select the Details tab.

3. Select the fulfillment element type to delete from the list at the left.

4. Click Delete icon on the toolbar.

5. Close the window. 

6. Save your changes.

1.1.42 Managing Fulfillment Elements
There are a number of tasks associated with fulfillment elements. These include:

■ Defining a new fulfillment element

■ Deleting a fulfillment element

■ Modifying a fulfillment element configuration

Defining a New Fulfillment Element
To add a new fulfillment element, perform the following tasks.

Prerequisites
The type of fulfillment element that you wish to add must exist before you can add 
the fulfillment element.

Warning: Each Fulfillment Element name must be unique and 
consist only of alphanumeric characters.
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Steps
1. In the Navigator, choose Setup > Interface Definition > Fulfillment Elements.

2. Select the Details tab.

3. Click the New icon on the toolbar.

This action causes a blank Details screen to open.

4. Complete the fields in the Details tab.

5. Complete the fields in the SW Versions tab, including both the Details and 
Attributes sub-tabs.

6. Close the window. 

7. Save your changes.

Deleting a Fulfillment Element
To delete a fulfillment element, perform the following tasks.

Prerequisites
You can not delete a fulfillment element, if either the following is true:

■ You have previously defined attributes for this fulfillment element.

■ You have previously defined the software generics for this fulfillment element.

Steps
1. In the Navigator, choose Setup > Interface Definition > Fulfillment Elements.

2. Select the Details tab.

3. Select the fulfillment element that you wish to delete from the list at the left.

4. Click Delete.

5. Close the window. 

6. Save your changes.

Warning: If you delete a fulfillment element, then the logical 
and physical entity of the fulfillment element is removed from 
the Service Delivery Platform database.
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Modifying a Fulfillment Element Configuration
If changing a fulfillment element configuration (for example, disabling a fulfillment 
element, or changing the fulfillment element attributes such as the IP address), 
perform the following steps.

Prerequisites
None.

Steps
1. Shutdown the Work Item queue to stop the work item dequeuers.

2. Ensure that there are no fulfillment actions remaining in the Wait for FE queue 
and the FE Ready queue. This means that all the fulfillment actions are 
processed at this point.

3. Shutdown the adapters for the fulfillment element.

4. Change the attributes for the fulfillment element.

5. Re-start the adapters for the fulfillment element.

6. Re-start the Work Item queue.

Creating an Activity or Process Timer
Perform the following steps to create either an activity or process timer.

Prerequisites
None

Steps

1. In the Navigator, choose Setup > Message Definition > iMessage Studio.

2. Click the New icon on the toolbar to create a new timer message.

A blank field opens in the Message Code list.

3. Enter a name for the new timer in the Message Code field.

The system uses this name for internal identification.

4. Select the Details tab.

The Elements and Structure tabs are grayed out. Timer messages come with 
two pre-defined, mandatory elements: Interval and Duration.

5. Select Timer from the drop-down list of available types.
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6. Enter a short name for the timer in the Display Name field.

7. Enter a brief description for the timer.

8. Select a priority for the timer.

This value sets the priority for the timer message in the Timer Message queue.

9. Select Timer Queue from the Queue Name drop-down list of values.

10. (Optional) Choose a responsibility for this message from the drop-down list of 
values.

11. Click the Save icon on the toolbar. 

You must save your work before proceeding.

12. Select the Data Source tab.

13. Select the tree root for the timer.

14. Select SQL Query from the Data Source Type drop-down list of values.

15. Select One and Only One from the Data Source Cardinality drop-down list of 
values.

16. Specify the source code for the timer in the Source field.

See the Source Guidelines following for details.

17. Select the Delay branch from the tree root for the activity timer.

18. Enter a reference for the Delay branch in the Reference field.

See the Delay Interval Guidelines following for details.
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19. Select the Interval branch from tree root for the Activity Timer. 

20. Enter a reference for the Interval branch in the Reference field.

See the Interval Guidelines following for details.

21. Click the Save icon on the toolbar. 

22. Select the Detail tab.

23. Click Compile to compile the timer.

If an error occurs, verify that you have followed steps 2 - 23 above correctly. 
After correcting the error, recompile the message.

24. Click the Close Form icon on the toolbar to close this form window.

Source Guidelines
The source SQL structure for the activity timer must be of the following format:

SELECT ’<D>’ DELAY, ’<I>’ INTERVAL FROM DUAL

Where

■ <D> is the delay integer value (in seconds)

■ <I> is the interval integer value (in seconds)

For example:

SELECT ’0’ DELAY, ’900’ INTERVAL FROM DUAL

Delay Guidelines
The reference value must be of the following format:

xnp$<activity_timer_name>.<select-list column name>

Where

■ <activity_timer_name> is the internal name defined in step 3 above.

■ <select-list column name> is the first select-list value of the SQL source 
specified in step 16. 

For example:

XNP$ACT_TIMER_1.DELAY
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Interval Guidelines
The reference value must be of the following format:

xnp$<activity_timer_name>.<select-list column name>

Where

■ <activity_timer_name> is the Internal Name defined in step 3 above.

■ <select-list column name> is the second select-list value of the SQL source 
specified in step 16.

For example:

XNP$ACT_TIMER_1.INTERVAL

Creating a Message Timer
Perform the following steps to create a message timer.

Prerequisites
Before creating the message timer, you must first create the message with which it 
is associated.

Steps
1. In the Navigator, choose Setup > Message Definition > iMessage Studio.

2. Click the New icon on the toolbar to create a new timer message.

A blank field opens in the Message Code list.

3. Enter a name for the new timer in the Message Code field.

The system uses this name for internal identification.

4. Select the Details tab.

5. Select Message from the drop-down list of available types.

6. Enter a short name for the timer in the Display Name field.

7. Enter a brief description for the timer.

8. Select a priority for the timer.

This value sets the priority for the timer message in the Timer Message queue.
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9. Select Outbound Message Queue from the Queue Name drop-down list of 
values.

10. (Optional) Choose a responsibility for this message from the drop-down list of 
values.

11. (Optional) Enter a path reference in the DTD Location field.

12. Click the Save icon on the toolbar. 

You must save your work before proceeding.

13. Use the Elements tab to add elements to the message.

14. Use the Structure tab to define the structure of the message.

15. Save your work before closing the window.

1.1.43 Workflow Procedure Guidelines
Use the following rules during procedure definition.

■ Use the provided procedure notepad to write your Service Fulfillment Manager 
procedure. 

■ Write an anonymous PL/SQL block as to insert into the procedure body.

■ Use capital letters for all PL/SQL reserved words and the constructs provided 
by Oracle Provisioning. 

■ Use the standard programming constructs provided by PL/SQL in your block 
of code, if desired.

■ Always add the EXCEPTION block at the end of the procedure.

Compiling Procedures
After creating a new procedure, you must compile it. The procedure builder 
prompts you with compilation errors if you have either of the following conditions 
exist:

■ The procedure contains PL/SQL syntax errors.

■ The procedure contains unrecognized parameters.
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1.1.44 The AOL Generic Loader
The Oracle Application Object Library loader is a general purpose data migration 
tool that is used for patching seed data, delivering translations, or copying setup or 
transaction data from development to production systems.

The loader is a concurrent program named FNDLOAD. To use this utility, enter the 
following command at a UNIX prompt.

FNDLOAD apps/pwd 0 Y mode configfile datafile entity [ param ... ]

The table following lists the parameters used with this executable and describes 
them.

Table 1-14  Lists of Parameters

Parameter Description

apps/pwd Specifies the APPS schema and password. 

■ If the connect_string is omitted, it is taken in a 
platform-specific manner from the environment using 
the name TWO_TASK

 0 Y Concurrent program flags

mode Specifies either UPLOAD or DOWNLOAD operation.

■ UPLOAD causes the specified data file to be uploaded to 
the database. 

■ DOWNLOAD causes the loader to fetch rows and write 
them to the specified data file.

configfile  Specifies the configuration file to use.

■ The configuration file usually ends with a suffix of.lct, but 
this rule is neither enforced nor supplied by the loader.

datafile Specifies the data file to write.

■ (DOWNLOAD) If the data file already exists, then it is 
overwritten.

■ The configuration file usually ends with a suffix of.lct, but 
this rule is neither enforced nor supplied by the loader.

entity Specifies the entity type to begin the download or upload. 

■ If you wish to upload all of the entity types in a data file 
(.ldt), specify a dash (-) as the entity type.
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Loader File Definitions
You can find the FNDLOAD configuration files for XDP at the following location:

$XDP_TOP/patch/115/import/*.lct

The table following lists the loader files used with Oracle Service Fulfillment 
Manager and provides the entities and download parameters supported by each. 

param Specifies zero or more additional parameters that are used to 
provide bind values in the access SQL (for both the UPLOAD 
and DOWNLOAD operations). 

■ Each parameter is of the form NAME=VALUE. The given 
NAME must not conflict with an attribute name for the 
entities being loaded.

Parameter Description
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See the contents of the individual configuration file for full documentation on 
usage.

The following tables lists dependencies between the various files.

Table 1-16  Lists of Dependencies 

Table 1-15 Loader File Description (Optional Download Parameters)

Name Description Entity Optional Download Parameters

xdpparpl.lct Parameter Pool XDP_PARAMETER_POOL  PARAMETER_NAME

xdpprbod.lct Procedure Body XDP_PROC_BODY PROC_NAME

xdpaccod.lct Action Codes XDP_ACTION_CODES ACTION_CODE

xdpfacts.lct Fulfillment Actions XDP_FULFILL_ACTIONS FULFILLMENT_ACTION

VERSION

xdpwipar.lct Work Items XDP_WORKITEMS WORKITEM_NAME

VERSION

xdpfetyp.lct Fulfillment Element 
Types

XDP_FE_TYPES FULFILLMENT_ELEMENT_TYPE

xdpfes.lct Fulfillment Elements XDP_FES FULFILLMENT_ELEMENT_NAME

xdpsrves.lct Services XDP_SERVICES SERVICE_NAME

VERSION 

xdppkges.lct Packages XDP_SERVICE_PACKAGES PACKAGE_NAME

PACKAGE_VERSION

Name Dependency

apps/pwd Specifies the APPS schema and password. 

■ If the connect_string is omitted, it is taken in a 
platform-specific manner from the environment using 
the name TWO_TASK

 0 Y Concurrent program flags

xdpfacts.lct First run xdpparpl.lct

xdpwipar.lct First run xdpparpl.lct

xdpfes.lct First run xdpfetyp.lct
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Several of the loader files also support optional upload parameters. The table 
following lists them.

References
For additional information, see the files in the following application directories.

■ Template configuration file

/fnddev/fnd/11.5/admin/import/fndstd.lct

■ Existing AOL configuration files

/fnddev/fnd/11.5/admin/import/*.lct

1.1.45 Event Subscription
Applications register with the Event Manager if they need information on specific 
messages (events) or all instances of that message type. An application can be an 
external system, an operating system or a mediation layer.

xdpsrves.lct First run xdpaccod.lct.

xdppkges.lct First run xdpsrves.lct.

Table 1-17 Loader File Description (Optional Upload Parameters

Name Upload Parameter Comments

xdpwipar.lct OVERRIDE_MAPPNG ■ If this command line argument is set to ’Y’, then all existing 
mappings from a work item to a fulfillment action are deleted 
first. Then, the mappings being inserted by the loader.

■ If this command line argument is set ’N’ or if it is not defined, 
mapping are inserted for a work item only if it did not exist 
previously.

xdpsrves.lct OVERRIDE_MAPPING ■ If this command line argument is set to ’Y’, then all existing 
mapping from service valid actions to work items are deleted 
first. Then the mappings are inserted by the loader.

■ If this command line argument is set ’N’ or if it is not defined, 
mapping are inserted for service valid actions only if it did not 
exist previously.

Name Dependency
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Every message and event is sent to the Event Manager which becomes the source of 
distribution for events and messages. This is known as event subscription. Event 
subscription is a business process handled within Workflow.

■ Applications can be set as default subscribers to specific events and messages. 
This is configured in the Event Subscriber utility.

■ Applications can show interest in a specific instance of a message by specifying 
the REFERENCE_ID of the message. 

■ Applications can register for one of several response messages by using the 
reference identifier. 

■ When a message with a reference identifier arrives, the Event Manager 
performs the following tasks:

■ It executes the validation logic.

■ It executes the processing logic. It does this before delivering the message to 
all registered applications.

■ Applications can show interest in all instances by registering with a NULL 
reference identifier.

■ If an application is registered for a specific instance, the registration is 
automatically unsubscribed after delivering that message.

■ Upon arrival of an expected response:

■ The message is delivered to the registered application.

■ The other expected response is marked EXPIRED.

Setting Up Event Subscription
In the Event Manager, it is possible for default subscribers to subscribe to specific 
events of the application. When a message occurs, the Event Manager ensures that 
an outbound message is automatically sent to the subscriber identified by a 
Fulfillment Element, OSS or gateway.
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Responding to an Event
■ It is possible to associate one or more responses to an event. 

■ A response is set during the configuration in the form of acknowledgments. 

Steps 
1. Create the message or event that is to the trigger for a response.

2. Configure an Acknowledgment/ Response to the message or event that you 
created in step 1.

3. Link the Acknowledgment that you created in step 2 to the message/event that 
you created in step 2.

Automatic Responses
If desired, you can associate one or more responses with an event. A response is an 
acknowledgment to a message. 

For example, valid message responses for the message "Is this an existing 
customer?" are:

■ "Yes, this is an existing customer."

■ "No, this is not an existing customer."

These responses are messages in themselves and must be configured in Oracle 
Service Fulfillment Manager Name before they can be linked as responses to a 
message. 

1.1.46 Administering the Oracle Service Fulfillment Manager
The Service Fulfillment Manager of various network elements is accomplished with 
the use of adapters. Adapters are processes which are specialized in certain 
protocols. (Telnet, FTP, or other protocols.). You direct the adapters to perform 
various tasks in the system.
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Oracle SFM Start
Application Start is a concurrent request that is performed by the Oracle Service 
Fulfillment Manager Concurrent Manager. 

You use the Application Start process to perform the following tasks:

■ Start the entire application, including the Controller, dequeuers and all 
adapters

■ Start only the Controller and the dequeuers

■ Start the Controller, the dequeuers and a subset of the adapters

The system automatically starts all the dequeuers and the Controller during the 
start process. If any dequeuers are already started, the number actually running is 
first determined, and matched against the number that are required to be started. 
The system automatically starts as many dequeuers as needed.

Prerequisites
Application Start and Stop are mutually exclusive processes. If one is pending, the 
opposite operation does not proceed until the first finishes. In addition, the Oracle 
Service Fulfillment Manager Concurrent Manager processes must be up and 
running. 

Note: To administer the Oracle Service Fulfillment Manager 
Concurrent Manager, open the Administer Concurrent Managers 
form window available through Concurrent > Administer 
Manager.

Note: You set the number of running dequeuers through the 
Queue Console, available through Administration > Queue 
Console.
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you 
mber 
Steps
1. In the a Navigator, select Applications > Start. 

The Parameters box opens.

2. Enter a value in the Options field from the drop-down list of values.

See the Guidelines following for information on these choices.

3. Enter a value in the Fulfillment Element field that is to be included (or 
excluded) from the application start process.

This choice depends on the value that you chose in step 2, preceding. Again, see 
the Guidelines for details.

4. Enter a value (0 - 3) for the Debug Mode.

This value sets the level of logging that can be used for debugging purposes.

5. Click OK.

The Oracle SFM Start dialog box becomes available. Parameters that you set in 
the previous dialog box display in the Parameters field.

6. (Optional) Click Copy, if you wish to use start parameters from a prior start 
request, otherwise proceed to step 7.

If you chose this option, then select from the provided list and continue to step 
10.

7. (Optional) Click Languages..., if you wish to change the default language used 
in generating the log entries, otherwise proceed to step 8.

If you chose this option, then place a check mark in the box next to the 
language, or languages, you wish to add. Continue to step 8.

8. (Optional) Click Schedules..., if you wish to change the default time at which 
this request is to be run. Perform either a or b, following.

a. Click Apply a Saved Schedule... to choose from a list of predefined 
schedules. 

b. Chose an option from the Run the Job... list.You can set how often, and when, 
wish the start request to run. Depending on which radio button you check, a nu
of additional fields display so that you may specify exact dates and times.
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9. (Optional) Click Options..., to specify to whom, and in what language, you 
wish a notification to be sent. You can also direct the output log files to be sent 
to a specific printer. 

10. Click Submit to initiate the start process and to close the dialog box.

Guidelines
Options: The table following lists the available choices. This option indicates which 
adapters are to be started. You must select from the provided list of values.

Table 1-18  Available Options for Adapters 

Fulfillment Element: Select the fulfillment element that is to be included or 
excluded (see the preceding table) from the application start. You must select from 
the provided list of values.

Debug Mode: Select the debugging mode to be used for the Controller and the 
dequeuer processes. You must select from the provided list of values.

Note: Each request generates a Request ID. You can use this 
Request ID to view the request status and the log entries through 
the View Requests form window, available through Concurrent > 
View Requests.

Option Description

ALL All adapters (for all fulfillment elements) marked AUTOMATIC 
are started.

(You set an adapter to AUTOMATIC through Administration > 
Connection Manager. You can also use the Adapter Properties 
form window to configure adapter properties.)

INCLUDE Only adapters marked AUTOMATIC that are associated with the 
designated fulfillment element are started.

EXCLUDE All adapters marked AUTOMATIC are started, except for those 
associated with the designated fulfillment element.

NONE No adapters are started.
Implementing Oracle Service Fulfillment Manager 1-109



Considerations for Planning an Implementation Project
The table following lists the available options.

Table 1-19  Loader File Description (Optional Upload Parameters)

Oracle SFM Stop
Application Stop is a concurrent request that is performed by the Oracle Service 
Fulfillment Manager Concurrent Manager. 

You use the Application Stop process to perform the following tasks:

■ Stop the entire application, including the Controller, dequeuers and all adapters

■ Stop a subset of the adapters

Prerequisites
Application Start and Stop are mutually exclusive processes. If one is pending, the 
opposite operation does not proceed until the first finishes. In addition, the Oracle 
Service Fulfillment Manager Concurrent Manager processes must be up and 
running. 

Debug Level Description

0 No trace

1 Minimum trace

2 Medium trace

3 Maximum trace

Note: Adapters are started with the debug level configured 
through the Adapter Properties window.
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you 
mber 
Steps
1. In the a Navigator, select Applications > Stop. 

The Parameters box opens.

2. Enter a value in the Options field from the drop-down list of values.

See the Guidelines following for information on these choices.

3. Enter a value in the Fulfillment Element field that is to be included (or 
excluded) from the application stop process.

This choice depends on the value that you chose in step 2, preceding. See the 
Guidelines for details.

4. Enter a value for the Stop Mode.

See the Guidelines following for information on these choices.

5. Click OK.

The Oracle SFM Stop dialog box becomes available. Parameters that you set in 
the previous dialog box display in the Parameters field.

6. (Optional) Click Copy, if you wish to use stop parameters copied from a prior 
stop request, otherwise proceed to step 7.

If you chose this option, then select from the provided list and continue to step 
10.

7. (Optional) Click Languages..., if you wish to change the default language used 
in generating log entries, otherwise proceed to step 8.

If you chose this option, then place a check mark in the box next to the 
language, or languages, you wish to add. Continue to step 8.

8. (Optional) Click Schedules..., if you wish to change the default time at which 
this request is to be run. Perform either a or b, following.

a. Click Apply a Saved Schedule... to choose from a list of predefined 
schedules. 

b. Chose an option from the Run the Job... list.You can set how often, and when, 
wish the start request to run. Depending on which radio button you check, a nu
of additional fields display so that you may specify exact dates and times.
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9. (Optional) Click Options..., to specify to whom, and in what language, you 
wish a notification to be sent. You can also direct the output log files to be sent 
to a specific printer. 

10. Click Submit to initiate the stop process and to close the dialog box.

Guidelines
Options: The table following lists the available choices. This option indicates which 
adapters are to be stopped. You must select from the provided list of values.

Table 1-20  Lists of Options for Adapters)

Fulfillment Element: Select the fulfillment element that is to be included or 
excluded (see the preceding table) from the application stop. You must select from 
the provided list of values.

Stop Mode: Select the mode to be used. You must select from the provided list of 
values.

Note: Each request generates a Request ID. You can use this 
Request ID to view the request status and the log entries through 
the View Requests form window, available through Concurrent > 
View Requests.

Option Description

ALL All adapters, for all fulfillment elements, dequeuers and the 
Controller are stopped. This option signifies the complete 
application stop.

INCLUDE Only adapters marked AUTOMATIC that are associated with the 
designated fulfillment element are stopped.

EXCLUDE All adapters marked AUTOMATIC are stopped, except for those 
associated with the designated fulfillment element.
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Table 1-21  Lists of Available Options)

1.1.47 Service Fulfillment Manager Procedure Macros
Oracle Service Fulfillment Manager comes with a set of predefined constructs that 
can be used to build procedures. These constructs are.

■ SEND

■ SEND_HTTP

■ LOGIN

■ RESPONSE_CONTAINS

■ GET_RESPONSE

■ GET_PARAM_VALUE

■ NOTIFY_ERROR

Debug Level Description

NORMAL This specifies the standard shutdown mode. Depending on the 
choice that you made under Options, this could be the entire 
system, or only a subset of it.
For example, if you select the NORMAL mode, and the Options 
value is set to ALL, then the following occurs:

■ If there are no adapters still processing orders, then all the 
dequeuers and the Controller are stopped.

■ If some of the adapters are still processing orders, all the 
dequeuers stop, except for the Event Manager. Once an 
adapter has finished processing an order, the Event 
Manager shuts the adapter down and a database job shuts 
down the Event Manager and Controller.

ABORT Specifies an abnormal mode of shutdown. All the 
running processes (as specified in the Options selection) 
are terminated at the operating system level.
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SEND
The SEND macro accepts a command string as an argument. This command string 
is sent to the fulfillment element as the command to be executed. You use the SEND 
macro to “send” commands to the network elements. 

Signature
The signature of the SEND construct is as follows:

SEND(<command > <varchar2>, <encrypt flag> <varchar2>, <prompt (optional)> <varchar2>, <err 
code (out)> <number>, <error string (out)> <varchar2>)

The application stores all the transactions sent and received, to and from the 
fulfillment elements in its audit trail. However, it also provides a mechanism that 
allows you not to store, or write sensitive information contained in the service order 
request to the audit trail, if desired. Responses from fulfillment elements may also 
carry the same sensitive information. 

Therefore:

■ If you set the encryption flag to Y, then you are disabling the logging of all 
responses from the fulfillment elements. 

■ If you set the encryption flag to N, then you are enabling the normal logging of 
responses from the fulfillment elements.

Syntax
The usage of the construct is defined as follows:

SEND(
<command> string which contains the command to be sent,this is where you specify your service 
parameters in $variable_name format. 
<‘Y’ or ‘N’> to indicate whether the command response must be logged into the audit trail,
<prompt> is an optional field which indicates the prompt at the Network Element after the execution 
of <command>>
<a number place holder for the out parameter error_code>,
<a varchar2 place holder for the out parameter error string>

);
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Restrictions
Note the following restrictions on the use of the SEND macro.

1. For parameter values with white spaces, specify the corresponding $variable_
names in double quotes.

2. Eliminate white spaces between SEND and the "(" following it.

Correct Usage: SEND(

Incorrect Usage: SEND (

3. Do not use SEND inside comments. 

SEND_HTTP
The SEND_HTTP macro accepts a command string as an argument. This command 
is then sent to the fulfillment element as the command to be executed using the 
HTTP protocol. Typically, in this scenario, the command is an URL. 

Signature
The signature of the construct is as follows:

SEND(
 <a string which contains the URL to be sent>  ,
<‘Y’ or ‘N’ indicator which indicates whether the URL should be logged into the audit trail>,
<a number place holder for the out parameter error_code>,
<a varchar2 place holder for the out parameter error string>
);

Restrictions
Note the following restrictions on the use of the SEND_HTTP macro.

■ Eliminate white spaces between SEND_HTTP and the "(" following it.

■ Incorrect Usage: SEND_HTTP ( 

■ Correct Usage: SEND_HTTP(
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LOGIN
The LOGIN macro accepts a command string as an argument. It uses the argument 
to initiate a connection. Use this macro to initiate a connection to a fulfillment 
element which has an interactive interface (for example, Telnet). 

Signature
The signature of the LOGIN construct is as follows:

LOGIN(
<a string which contains the command to be sent>  ,
< a string which contains the command response expected>,
<a number place holder for the out parameter error_code>,
<a varchar2 place holder for the out parameter error string>
);

SEND (Connection Procedure)
This SEND macro accepts a command string as an argument. It uses the argument 
to send the command set (connect) to the fulfillment element. One of the connection 
commands is executed. 

Signature
The signature of the LOGIN construct is as follows:

SEND(
 <a string which contains the command to be sent>  ,
< a string which contains the command response expected>,
<a number place holder for the out parameter error_code>,
<a varchar2 place holder for the out parameter error string>
);

Note: The LOGIN construct should appear before the first SEND 
construct in the procedure.
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Restrictions
Note the following restrictions on the use of the LOGIN macro.

1. Use the LOGIN macro once only before any SEND construct.

2. Use the LOGIN macro only in a connect procedure.

3. Do not use order, line, work item, and fulfillment action as service parameters. 
The $ variables are fulfillment element attributes, and, as such, can not be used 
as service parameters.

RESPONSE_CONTAINS
The RESPONSE_CONTAINS procedure macro is a PL/SQL function that compares 
a user-defined string against the string returned by a fulfillment element in 
response to the last command that it received. The macro returns TRUE if the two 
strings match, otherwise it returns FALSE.

Signature
The signature of the construct is as follows:

RESPONSE_CONTAINS(
    <a string which contains the string to be matched>
  ) 
    return BOOLEAN;

Restrictions
Note the following restrictions on the use of the RESPONSE_CONTAINS macro.

1. Do not use $ variables.

2. Eliminate white spaces between RESPONSE_CONTAINS and the "(" following 
it.

■ Incorrect Usage: RESPONSE_CONTAINS (

■ Correct Usage: RESPONSE_CONTAINS(
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GET_RESPONSE
The GET_RESPONSE macro returns the response string from the fulfillment 
elements for the last command sent. 

Signature
The signature of the construct is as follows:

GET_RESPONSE return VARCHAR2

Syntax
The usage of the construct is defined as follows:

  err_code number;
  err_str     varchar2(400);
  lv_user varchar2(80);
BEGIN
  lv_user := GET_PARAM_VALUE(‘$WI.user’);
SEND(‘AddProfile -h $WI.hostname -p $FA.dbport -u $WI.user’, ‘Y’, err_code, err_str);
IF RESPONSE_CONTAINS(‘profile already exist’) THEN
  NOTIFY_ERROR(‘Error when Service Fulfillment Manager Cisco Secure HA Server. Subscriber ‘ || 
lv_user || ‘ already exists’,’A’); 
  RETURN;
END IF;
EXCEPTION
  WHEN OTHERS THEN
  RAISE;
END;

Restrictions
Note the following restrictions on the use of the GET_RESPONSE macro.

1. Do not use $ variables.

2. Eliminate white spaces between RESPONSE_CONTAINS and the "(" following 
it.

■ Incorrect Usage: GET_RESPONSE (

■ Correct Usage: GET_RESPONSE(
1-118 Oracle Service Fulfillment Manager Implementation Guide



Considerations for Planning an Implementation Project
GET_PARAM_VALUE
Use the GET_PARAM_VALUE procedure macro to obtain the value of the 
parameter during run-time. 

Signature
The signature of the construct is as follows:

GET_PARAM_VALUE (<parameter name> <varchar2>) return VARCHAR2

■ The <parameter name> is the name of the parameter in $ format. 

■ The value returned by the function can be NULL.

When using this macro, specify the parameters as a $ variable. For example, 
parameter TN (if used inside a Service Fulfillment Manager procedure), is specified 
as $ORDER.TN.

Restrictions
Note the following restriction on the use of the GET_PARAM_VALUE macro.

■ Eliminate white spaces between GET_PARAM_VALUE and the "(" following it.

■ Incorrect Usage: GET_PARAM_VALUE (

■ Correct Usage: GET_PARAM_VALUE(

NOTIFY_ERROR
The NOTIFY_ERROR procedure macro indicates an abnormal exit point from the 
procedure. The Service Fulfillment Manager of a service order request at a 
fulfillment element has an ERROR status. 

This macro appends or replaces a response initiated by the fulfillment element / 
network element. This is the input string. 
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Signature
The signature of the construct is as follows:

NOTIFY_ERROR(<user’s string> <varchar2>, <mode> <char>)

■ The <user’s string> contains a user-defined friendly message

■ The <mode> flag is either A or R. 

A indicates that the user message is to be appended to the response string 
coming from the fulfillment element.

R indicates that the user message is to be replaced by the response string 
coming from the fulfillment element.

Guidelines
1. You use this macro under the following conditions:

■ You want to identify errors coming from the fulfillment element during the 
Service Fulfillment Manager process.

■ You want to identify errors when exiting from the Service Fulfillment 
Manager procedure. 

2. You use the NOTIFY_ERROR macro to abort a Service Fulfillment Manager 
procedure.

3. You must follow every NOTIFY_ERROR instance in the procedure by a 
RETURN statement. This is the only way to abort the execution of the Service 
Fulfillment Manager procedure.

4. The Service Delivery Platform uses the <user’s string> to display the Service 
Fulfillment Manager errors of a failed Service Order Request. Make this name 
user-friendly. This name provides the ability to translate cryptic network 
element error messages into those that are more user friendly.

1.1.48 Example Service Delivery Platform Procedures
Following are several example workflow procedures:

■ Service Fulfillment Manager procedure

■ Connect procedure

Service Fulfillment Manager Procedure
The following is an example of a Service Fulfillment Manager Procedure
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DECLARE
err_code number;
err_str     varchar2(400);
lv_user varchar2(80);
BEGIN
lv_user := GET_PARAM_VALUE (‘$user’);
  SEND(‘AddProfile -h $hostname -p $dbport -u $user’, ‘Y’, err_code, err_str);
  IF RESPONSE_CONTAINS (‘profile already exist’) THEN
     NOTIFY_ERROR(‘Error when Service Fulfillment Manager Cisco Secure HA Server. Subscriber ‘ || 
lv_user || ‘ already exists’,’A’); 
RETURN;
 END IF;
EXCEPTION
WHEN OTHERS THEN
   RAISE;
END;

Connect Procedure
The following is an example of a Connect Procedure

DECLARE
err_code number;
err_str     varchar2(400);
lv_user varchar2(80);
BEGIN
LOGIN(‘telnet $ip_address’, ‘login:’, err_code, err_str);
SEND(‘$username’, ‘$Password:’, err_code, err_str);
SEND(‘$Password’, ‘$’, err_code, err_str);

EXCEPTION
WHEN OTHERS THEN
   RAISE;
END;
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1.1.49 Workflows

Using Timers in Workflow
You can build timer functionality into your user-defined Workflow by using a set of 
drag-and-drop activities provided by Oracle Service Fulfillment Manager. These 
activities are part of the SFM Standard item type.

The table following lists the activities that can be associated with timers in 
Workflow:

Table 1-22  Activities Associated with Timers in Workflow)

Function Name Description

Deregister Remove all timers for a given order

Fire Timer Function to start either a process or activity timer

Send Message Function that sends a message which has a timer associated with 
it

Start Related Timers Function to start either an activity timer or a timer associated 
with a message

Subscribe to 
Acknowledgements

Function to subscriber for possible results from the Send 
Message function

Get Jeopardy Flag Checks whether or not a jeopardy timer exists for a given order

Get Timer Status Returns the status of a timer

Recalculate all 
timers

Recalculates the delay and interval elements for all timers 
associated with the given the Work Item name, Instance ID, 
Order ID, or the Fulfillment Action Instance ID.

Remove Timer Deletes the timer with the given name
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Activity Timers in Oracle Service Fulfillment Manager
An Activity Timer is used in conjunction with a workflow activity. The purpose of 
an Activity Timer is to provide the ability to set a pre-defined period of time within 
which a workflow activity must be completed.

For example, a workflow activity is defined to check the network capacity for a 
requested data service. The time period to perform the workflow activity is set to 30 
minutes. An Activity Timer is then associated with the workflow activity to handle 
the required business logic if the 30 minute time frame for the activity is exceeded.

Process Timers in Oracle Service Fulfillment Manager

A Process Timer is used in conjunction with a Workflow process. The purpose of a 
Process Timer is to provide the ability to set a pre-defined period of time within 
which a Workflow process must be completed.

For example, a workflow process is defined to provide a requested data service. The 
time period to perform the Workflow process is set to one business day. A Process 
Timer is then associated with the workflow process to handle the required business 
logic if the one day time frame for the process is exceeded.
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Message Timers in Oracle Service Fulfillment Manager
A Message Timer is used in conjunction with a message. The purpose of a Message 
Timer is to provide the ability to set a pre-defined period of time within which a 
message acknowledgment must be received.

For example, a workflow process is defined to set up an account for a network 
service. A message is sent to the associated network service administrator. If a reply 
is not received back with in 30 minutes, then the timer message is published and 
picked up by the workflow activity that is Waiting for the Acknowledgments. The 
acknowledgment may be a message reply or a timer in which the workflow follows 
a path based on the message received.

The Waiting For Acknowledgments activity subscribes to events. An event can be 
configured to include an acknowledgment for the message sent out, as well as a 
timer. Depending on the message received, the workflow progresses.

Workflow in Oracle Service Fulfillment Manager

Workflows are processes that execute during the main Service Fulfillment Manager 
process to process and fulfill the order. Workflows can be run before starting the 
service Service Fulfillment Manager process.

You use the Oracle Workflow Builder to configure the workflows to be executed 
during the Service Fulfillment Manager process. The workflow can be invoked for a 
work item or a fulfillment action. 

The main Service Fulfillment Manager workflow waits until all sub-processes 
complete their activities before continuing to fulfill the order.

If an error occurs during the main Service Fulfillment Manager process, you can 
intervene manually and launch appropriate workflows as the situation dictates. 
You can launch any workflow process in Oracle Service Fulfillment Manager, as 
necessary.

The Workflow Builder
Refer to the Oracle Workflow Guide for details of the workflow builder.

Workflow Processing of a Service Order Request
During the execution of a service order, the line items associated with it are 
processed by workflow. Which fulfillment procedures execute depend on the type 
and software generic of the fulfillment element configured in Oracle Service 
Fulfillment Manager. 
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■ The mapping between fulfillment procedure and fulfillment element is 
specified in the Service Creation Manager.

■ The fulfillment procedure involves sending commands to a fulfillment element, 
receiving, and analyzing responses to determine success or failure of 
commands. 

■ The procedures are written in PL/SQL which has been extended with open 
APIs.

■ A watchdog workflow detects the termination of adapter processes and 
manages their recovery. 

■ When all adapters for a given fulfillment element are shutdown, suspended, 
disconnected or goes down, all service order requests for that fulfillment 
element are queued until the adapter is up again and ready to process the next 
fulfillment action in the queue. 

 Steps Involved in Processing a Service Order Request

■ A service order consists of many line items. A line item can be either a service 
or a package.

■ Each line item can be mapped to multiple work items.

■ Each work item is mapped to a set of fulfillment actions via different means. 
(For example, this could be either a static or dynamic fulfillment action, 
workflow, or a workflow procedure.)

■ Each fulfillment action invokes one fulfillment procedure at runtime depending 
on the type of fulfillment element.

■ Each procedure is executed on one fulfillment element. 

■ The identity of the fulfillment element to be provisioned is determined through 
routing rules implemented through user-defined PL/SQL procedure. 

■ Error conditions detected during Service Fulfillment Manager cause the 
workflow to send error notifications.

■ The workflow waits for the notification response. 

■ The response indicates how the error condition is to be handled.
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The Workflow Monitor
The Workflow Monitor utility provides a graphical interface to track a service 
order’s path in Oracle Service Fulfillment Manager. When launched, it opens in a 
web browser screen.

Using the graphical interface, you can:

■ View each activity performed on an order. 

■ View the route of an order from the beginning to the end. 

■ Retrieve statistical information and branching activities for each node displayed 
on the workflow path.

1.2 Workflow Activity Functions

1.2.1 Standard Function Activities Provided by Oracle Number Portability
You receive the following number portability standard function activities with the 
application:

Table 1-23  Standard Function Activities in Number Portability)

Name Description

Check Flag Value Checks the flag value for the given PORTING_ID workitem 
parameter.

Check if Donor is 
eligible to Port Out

Checks whether or not the donor service provider in this porting 
transaction has provisioned the number range, or has assigned 
the number range.

 If either condition is true, then the activity completes with Y.

Check if Donor is 
Initial Donor

Checks whether or not this donor is also the initial donor.

Create or Modify 
SMS Porting Records

Creates or modifies a Porting Record for each telephone number 
in the range. The Porting ID for the first record is the same as 
that set in the work item parameter.

Create Porting Order Creates a porting order based on the Service Provider role.
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Deprovision FEs Sets the fulfillment elements to be deprovisioned for this feature 
type and number range. For each fulfillment element, the Oracle 
Service Fulfillment Manager provisioning procedure (Execute 
FA) is invoked.

At the end of this activity, control passes to the provisioning 
subsystem which executes the fulfillment procedure. An FA_
DONE message is subscribed for each fulfillment action being 
executed which gives the execution result of the fulfillment 
procedure. The callback procedure associated with the FA_
DONE handles the responses received.

The immediate next activity following this activity must be the 
Oracle Service Fulfillment Manager Standard Wait For Flow. 
This is to ensure proper hand-off from the provisioning system 
back to the Number Portability system.

Only fulfillment elements that were earlier provisioned by this 
service provider can be modified. Otherwise, the fulfillment 
elements are ignored.

Determine Current 
Service Provider 
Role

Determines whether or not a given service provider is the donor, 
original donor, or recipient for the current porting transaction, 
and completes the activity with the appropriate result code.

Determine if 
Subsequent Porting 
Request

Checks whether or not this is a subsequent porting request.

Returns either Y or N.

Does Porting Record 
exist for Donor

Check whether or not there exists a porting record with the 
given status in this telephone number range that belongs to the 
given donor’s service provider ID.

Returns either Y or N.

Does Porting Record 
exist for Recipient

Check whether or not a porting record with the given status 
exists in this telephone number range that belongs to the given 
recipient’s service provider ID.

Returns either Y or N.

Get Porting Status Retrieves the status of the porting record for the given PortingID

Prepare Notification 
Message

Prepares a default notification message.

Name Description
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Provision or Modify 
Provisioned FEs

Sets or retrieves the fulfillment elements to be provisioned or 
modified for this feature type and number range. For each 
fulfillment element, the Service Delivery Platform’s provisioning 
procedure (Execute FA) is invoked.

At the end of this activity, control passes to the provisioning 
subsystem which executes the fulfillment procedure. An FA_
DONE message is subscribed for each fulfillment action being 
executed which gives the execution result of the fulfillment 
procedure. The callback procedure associated with the FA_
DONE handles the responses received.

The immediate next activity following the activity must be SFM 
Standard Wait For Flow. This is to ensure proper hand-off from 
the provisioning system back to the Number Portability system.

Only fulfillment elements that were earlier provisioned by this 
service provider can be modified.

Set Date Value Sets the Date value

Set Flag Value Sets the flag to the given value for the entries in XNP_SV_SOA 
for the given PORTING_ID workitem parameter, and FLAG_
NAME for the current Service Provider.

The Value is 'Y' or 'N’.

Set SMS 
Provisioning Done 
Date

Sets the date when the Service Management System completes 
provisioning

Update Charging 
Information

Updates the Subscription Version in the Service Order 
Administrator for each telephone number with the given Porting 
ID, with invoice information.

Update Comments 
and Notes 
Information

Updates the comments and notes for the current Porting ID and 
the current service provider.

Update Customer 
Information

Updates the customer information for the current Porting ID and 
the current service provider.

Update Network 
Information in SOA

Updates the network information in the XNP_SV_SOA for the 
current Porting ID and the current service provider.

Name Description
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TPredefined Work Items in Oracle Number Portability
Work items are organized into groups known as item types. The following table 
lists the standard item types delivered with Oracle Number Portability.

Update Porting 
Status for Number 
Range

Updates the status type code in the XNP_SV_SOA with the new 
status type code. All records with the porting ID belonging to 
the current service provider are updated to the new status.

If the new status belongs to the ACTIVE phase, and if records 
exist for this number range in ACTIVE phase, then these records 
are first reset to the OLD phase. The actual update of the records 
with the given porting ID is performed after this step.

Update Porting 
Status for Porting Id

Updates the status type code in the XNP_SV_SOA with the new 
status type code. All records with the porting id and belonging 
to the current service provider are updated to the new status. If 
the new status belongs to the ACTIVE phase, and if there exists 
records for this number range already in ACTIVE phase, then 
they first are reset to OLD phase. The actual update of the 
records with the given porting id is done next.

Validate Runtime 
Data

Validates runtime data

Verify Porting Status Checks if the STATUS_TYPE_CODE from XNP_SV_SOA for the 
given PORTING_ID is same as the given status type code (in 
STATUS_TO_COMPARE_WITH).

 Returns T if the two statuses match.

 Returns F if the two statuses do not match.

Name Description
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Table 1-24 Standard Item Types in Number Portability

Note: Do not modify any of the standard Oracle Number 
Portability item types, except NP Processes.

Item Type Internal Name Description Customizable

Standard WFSTD Contains standard function activities that 
are commonly used to create business 
processes.

No

SFM 
Standard

XDPWFSTD Contains function activities that are 
commonly used across both the Oracle 
Service Fulfillment Manager and Oracle 
Number Portability applications.

The following are examples of functions:

■ Send Message

■ Subscribe to Acknowledgments

No

SFM 
Lookup 
Code

XDPCODES Contains lookup types used for easy 
selection in workflow activities. This could 
be, for example, a list of fulfillment 
actions, or a list of messages.

No

NP 
Standard

XNPWFSTD Contains function activities that are 
specific to Oracle Number Portability. Use 
these activities in the implementation of 
your business processes.

The following are examples of standard 
functions:

■ Creating a porting order

■ Determining if porting is possible

No

NP Lookup 
Code

XNPTYPES Contains lookup types used for easy 
selection in workflow activities. This could 
be, for example, a list of fulfillment 
actions, or a list of messages.

No
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Guidelines
5. In general, you should use the SFM Standard and NP Standard function 

activities whenever possible, and only customize the Number Portability 
activities as absolutely necessary.

6. SFM Lookups and NP Lookups must be updated as you start to configure 
Oracle Service Fulfillment Manager. Run the Lookups Loader API to update 
these item types.

1.2.2 Predefined Fulfillment Element Types in Oracle Number Portability
The Oracle Number Portability application is preseeded with a number of 
fulfillment element types. The following table lists these predefined element types.

Table 1-25  Predefined Element Types in Number Portability)

1.3 Testing an Implementation Project

1.3.1 Submitting a Test Order
You use the Quick Order Entry window to create a new service order for testing 
purposes.

Element Type Description

BILLING_
GATEWAY

Refers to billing system gateway

DIRECTORY_
GATEWAY

Refers to directory assistance gateway

NRC_GATEWAY Refers to the Number Registration Center gateway

SCP Refers to the LNP database for all service control points

SP_GATEWAY Refers to messaging gateways for remote systems of other 
service providers

SSP Refers to signal switching point

STP Refers to signal transfer point
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Prerequisites
None

Steps
1. In the Navigator, choose Test Center > Test Order.

A blank Quick Order Entry form window opens.

2. Select the Order Header tab.

3. Enter an order number.

■ If you want to create a new test order, enter its order number here.

■ If an order is already defined, enter its order number to populate the form 
window. This information is read-only, and can not be modified.

■ If you do not know the order number for an existing order, click Find 
Orders and perform a search for it using the Find Orders dialog box.

4. (Optional) Enter an order version.

5. (Optional) Select Order Type, and choose a value from the drop-down list. 
(Typically, this is External System Order.)

6. (Optional) Enter customer information.

If your installation is customized and integrated with a customer care system, 
then enter a value. Otherwise, ignore the customer fields, they are used for 
searching purposes only.

7. Enter a value for Service Fulfillment Manager Date.

This is the date on which porting activation is to take place. Use the Calendar 
selection tool, if desired. You can also enter values for Customer Required Date, 
and Due Date, if you want these fields to be used for search queries.
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8. (Optional) Click Order Params to open the Order Parameters selection dialog 
box.

If desired, select an order parameter from the drop-down list of values, and 
enter a value for it in the Parameter Value field. Click OK to save and close the 
dialog box.

9. (Optional) Select the Line Items tab.

You use this dialog box to set information about services associated with this 
order.

a. Select the Details tab.

Depending on the order type that you selected in step 5, different fields 
display. 

If you selected External System Order, then fields pertaining to services 
display.

If you selected Number Portability System Order, then fields pertaining to 
work items display.

b. Complete the fields in the Details tab as necessary.

c. Complete the fields in the Sequence tab as necessary.

d. Click Line Parameters to open the Line Item Parameters dialog box. 

Use this dialog box to associate a line item parameter and value with the 
order. Click OK to save your entries and close the dialog box.

10. Click Submit to generate a test order.

1.4 Considerations for Future Upgrade Paths
The following are considerations for future System-Level upgrades:

■ System Profiles

■ Enabled Workflows

■ Employees and Security

■ Multicurrency capabilities

■ Customization Issues
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